#11226 closed defect (fixed)

XEEN: World of Xeen CD does not show gold/exp/gems properly

Reported by: Scorpeg Owned by: dreammaster
Priority: high Component: Engine: Xeen
Keywords: Nintendo Switch, MacOS Cc:
Game: Might and Magic: World of Xeen

Description (last modified by Scorpeg)

ScummVM is latest build https://buildbot.scummvm.org/snapshots/master/switch-master-latest.zip

Might & Magic - World of Xeen CD talkie version

Horizon OS 8.1

I believe this is Switch build bug, as on PC all shows properly.

Images displaying the defect are in attachment.

Attachments (2)

2019102210132900-F1C11A22FAEE3B82F21B330E1B786A39.jpg (234.5 KB ) - added by Scorpeg 12 months ago.
2019102210133600-F1C11A22FAEE3B82F21B330E1B786A39.jpg (175.9 KB ) - added by Scorpeg 12 months ago.

Download all attachments as: .zip

Change History (10)

comment:1 by Scorpeg, 12 months ago

Description: modified (diff)

comment:2 by priiice, 12 months ago

I'm using the macOS 2.1.0 release binary (built 2019/10/12) along with the CD version (cobbled together from GOG as per the readme instructions) and I am experiencing the same issue.

comment:3 by Scorpeg, 12 months ago

Keywords: MacOS added

comment:4 by dreammaster, 12 months ago

Component: PortsEngine: Xeen
Summary: Might & Magic - World of Xeen CD does not show gold/exp/gems properlyXEEN: World of Xeen CD does not show gold/exp/gems properly

Just to be clear, I presume by "PC all shows properly" you mean that the same savegame shows correctly on the PC, but not on the Switch without doing anything but loading the saveagme and opening the character screen?

Note to myself: One interesting aspect of the display is that the number being shown is greater than the maximum allowable 32-bit integer. I'm wondering if perhaps the format specifier being used for displaying the gold amount is being treated as a 64-bit type for Switch, and not for PC. I'll have to double-check it to rule it out.

comment:5 by Scorpeg, 12 months ago

Actually it is not a savegame, it is a new game start without doing anything, apart opening character screen. On PC shows normally, but on Switch and it seems on MacOS - no. I suppose your guess about format being used is correct, as it really looks like it uses 64bit instead 32bit.

comment:6 by dreammaster, 12 months ago

Owner: set to dreammaster
Resolution: fixed
Status: newclosed

Okay, I think I've got this sorted out. It was indeed a mismatch on some of the format specifiers against the gold, gems, and experience.

comment:7 by dreammaster, 12 months ago

Resolution: fixed
Status: closednew

Re-opening, because the problem is still in the Quick Reference dialog. And I should really update the strings in the create_xeen tool

comment:8 by dreammaster, 12 months ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.