Opened 4 months ago

Closed 4 months ago

#11216 closed defect (fixed)

QFG3 crash when leaving to Village with Johari

Reported by: tomasz89 Owned by: sluicebox
Priority: normal Component: Engine: SCI
Keywords: original Cc:
Game: Quest for Glory 3

Description (last modified by tomasz89)

There is a ScummVM crash when leaving for the Leopard village with Johari.

Invalid arithmetic operation (modulo - params: 0000:0000 and 0000:0000) from method walkJohari::doit (room 170, script 170, localCall ffffffff)!

One theory I have is that because it's night time; the Hero may want to sleep. However this was frequently the condition when I played under DOS and have seen it work.

Save attached.

GOG version of QFG3.
Git version: ba6834c96e33723ad16f7d7fbaaba17a5e35e91d
Compiled with SCI/SCI32 on Linux Ubuntu 19.04.

Attachments (1)

qfg3-GOG.017 (53.9 KB ) - added by tomasz89 4 months ago.
Just about to leave screen.. crash when Johari dialog appears on next screen

Download all attachments as: .zip

Change History (7)

by tomasz89, 4 months ago

Attachment: qfg3-GOG.017 added

Just about to leave screen.. crash when Johari dialog appears on next screen

comment:1 by tomasz89, 4 months ago

Description: modified (diff)

comment:2 by tomasz89, 4 months ago

Description: modified (diff)

comment:3 by tomasz89, 4 months ago

Confirmed that I managed to leave with Johari during the daytime without issue.

comment:4 by sluicebox, 4 months ago

Keywords: original added
Priority: blockernormal

From the the amazing QFG3 fan patch...

"Fixed a crash that would occur when the player reentered the map with Johari too closely to the Leopardman Village."

I don't know QFG3 but I'll take a look at this eventually if no one else does. I'd start by checking out how it's already been fixed. Setting priority to normal since it's a known script bug in the original.

comment:5 by sluicebox <22204938+sluicebox@…>, 4 months ago

In 08191db:

SCI: Fix QFG3 Johari and Manu map bugs

Fixes bug #11216

comment:6 by sluicebox, 4 months ago

Owner: set to sluicebox
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.