Opened 12 months ago

Closed 4 weeks ago

Last modified 11 days ago

#11210 closed defect (fixed)

AGI: Mixed-Up Mother Goose (AppleIIgs) - possible issue with MUMG and other AGI games

Reported by: Maxor127 Owned by: ZvikaZ
Priority: low Component: Engine: AGI
Keywords: IIgs Cc:
Game: Mixed-Up Mother Goose

Description

I played through the IIgs version of Mixed-Up Mother Goose, and I noticed sometimes the music cuts off during some of the nursery rhyme sequences. I then realized the music seemed to stop when a sound effect played during the sequence as if the sound effect was causing the music to cut out. And sometimes the nursery rhyme text seemed to freeze without finishing the rhyme. Both the music and text issues can be observed after returning the pail to Jack and Jill.

I then tried it in a IIgs emulator, and I noticed the sequence seemed to play without those issues, but if I increased the emulation speed, I had the same issues as ScummVM. So I'm guessing it's some sort of speed or timing issue and the sequence is playing faster than it should, but I could be completely wrong.

For what its worth, I tried the DOS AGI version, and the same sequence seems to play fine. When I set the in-game speed to "fastest," the nursery rhyme sequence slowed down to "normal" speed.

I suspect other IIgs games are affected with speed issues too. I think it's more noticeable in Mixed-Up Mother Goose because it seems to have more cutscenes than other AGI games.

The IIgs Sierra characters do seem to move faster in ScummVM compared to "normal" IIgs speed, but I actually like the faster speed. Original IIgs speed always felt a bit too slow and stuttery.

I've experienced the issue as of ScummVM 2.1.0.

Attachments (3)

mixedup-2gs.001 (6.0 KB ) - added by Maxor127 3 months ago.
activegs.mp4 (1.4 MB ) - added by Maxor127 6 weeks ago.
Cutscene in ActiveGS emulator
scummvm.mp4 (904.2 KB ) - added by Maxor127 6 weeks ago.
Cutscene in ScummVM 2.1.2

Change History (17)

comment:1 by digitall, 12 months ago

Component: --Unset--Engine: AGI
Game: Mixed-Up Mother Goose

comment:2 by ZvikaZ, 4 months ago

Can you supply a save game?

comment:3 by raziel-, 3 months ago

Summary: possible issue with Mixed-Up Mother Goose IIgs and other AGI gamesAGI: Mixed-Up Mother Goose (AppleIIgs) - possible issue with MUMG and other AGI games

by Maxor127, 3 months ago

Attachment: mixedup-2gs.001 added

comment:4 by Maxor127, 3 months ago

I've attached a save game file right before delivering the pail to Jack and Jill. Just walk close to them to see the cutscene.

comment:5 by ZvikaZ, 3 months ago

When you play the game in an emulator (with regular speed), what exactly the behaviour is?
Does the rhyme and the sound effect play together, and the rhyme music continues after the sound effect ended?
Maybe the sound effect is played only after the rhyme music has finished?
Or maybe the music is halted, we hear the sound effect, and then the music continues?
Or something else?
Can you supply a video recording?

Last edited 3 months ago by ZvikaZ (previous) (diff)

comment:6 by ZvikaZ, 3 months ago

Don't bother with video recording.
I think I understand the problem.

From the options I gave above, the correct one is:

Maybe the sound effect is played only after the rhyme music has finished?

Correct?
If not, please answer my question from the previous post :-)

comment:7 by ZvikaZ, 3 months ago

I've prepared a possible fix (if I understand the problem correctly ;-) )
Can you check it?

git clone https://ZvikaZ@github.com/ZvikaZ/scummvm.git
git checkout z_temp

and compile.

Or, if you prefer, I can upload a .exe file.

by Maxor127, 6 weeks ago

Attachment: activegs.mp4 added

Cutscene in ActiveGS emulator

by Maxor127, 6 weeks ago

Attachment: scummvm.mp4 added

Cutscene in ScummVM 2.1.2

comment:8 by Maxor127, 6 weeks ago

Sorry, I don't know how to compile source code. I recorded videos, and I noticed ScummVM is now finishing the rhyme text for some reason, when I think it consistently wouldn't show the last line of text before.

I have trouble finding good Apple IIgs emulators for Windows, so I tested on KEGS and couldn't get it to load for some reason. I then used ActiveGS, which I think is based on KEGS, and it worked. I'm not sure how accurate it is since I haven't played games on a real IIgs in 30 years. But you can see in the ActiveGS video, the cutscene speed is slower, so you hear more music and sound effects.

To make things more complicated, I noticed the DOS version's text seems to sync with the actions of the cutscene, so "Jack fell down..." appears as soon as he falls, and "And Jill came tumbling..." appears as soon as she falls. I'm not sure if that's supposed to happen in the IIgs version or not, since the IIgs version has extra sound effects and for the cutscene to sync with the text, the sound effects would have to play at the same time as the music.

comment:9 by ZvikaZ, 6 weeks ago

The DOS version is irrelevant.
It has different game files.

Please check:
https://github.com/ZvikaZ/scummvm/files/5213059/scummvm.zip

comment:10 by Maxor127, 4 weeks ago

It looks good.

What was changed? Is this something that affects only this game or does it potentially affect other 2gs games? Is it only this cutscene or other cutscenes?

comment:11 by ZvikaZ, 4 weeks ago

Good questions...

There was an issue with 2gs speed in cutscenes.
You can read the details at https://bugs.scummvm.org/ticket/7026

To summarize, ScummVM runs the game faster than the real 2gs hardware, and that causes problems video/audio mismatches in several cutscenes in some games.

In order to solve that, there was added a mechanism that returned the games to its original, slower, speed, in specific locations.

My fix to your report was simply to add that scenario in MG to the the table of the locations that needed slowing down.

Now that you've confirmed that it's actually solve your problem, I will send it as PR.

It's possible that there are more placed needing slowing down - feel free to report them as well, and I will add them too.

BTW,
If you're interested in 2gs speed, I've recently added an option to change the games speed in 2gs (just like there is such menu in Dos).
You need to enable it under the "engine" tab of the specific game, and then you'll have a speed menu in the game's menu.

comment:12 by sev-, 4 weeks ago

Fixed by @ZvikaZ

comment:13 by sev-, 4 weeks ago

Owner: set to ZvikaZ
Resolution: fixed
Status: newclosed

comment:14 by Maxor127, 11 days ago

Will other MUMG scenes need to be individually fixed too? I think all of them had speed issues.

I also found more speed/audio sync issues with intros of other games, and I'm not sure if I should post them here or in the other ticket you linked or create a new ticket.

One of them is Mixed-Up Mother Goose again, whose intro ends before the music is finished.

Note: See TracTickets for help on using tickets.