Opened 16 years ago

Closed 16 years ago

Last modified 13 months ago

#1119 closed defect (fixed)

All: Wrong Adlib volumes regression

Reported by: SF/logicdeluxe Owned by: Kirben
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Indiana Jones 3

Description

ScummVM 0.5.3cvs (Aug 5 2003 21:47:28)
windows
Playing with '-eadlib'.
Some examples: In the MI2's title sequence the base
line is unusual quite, then when the text "deep in the
Caribbean" appears the chord suddenly jumps to a much
louder level. During the camp fire scene, the chords
and drums are playing a lot louder then the rest of the
tune. At part one, the chords then are a lot quiter
than the drums and the flute. Also very noticeable with
the Indy4 opening, where the snares are very much
louder than the Indy fanfares. And much more. Those
errors follow you through all games with Adlib music.
This only affects Adlib. The music plays still fine
with native midi.
This appeared between ScummVM 0.5.3cvs (Aug 5 2003
02:53:13) and ScummVM 0.5.3cvs (Aug 5 2003 19:17:10)

Ticket imported from: #783477. Ticket imported from: bugs/1119.

Change History (5)

comment:1 by Kirben, 16 years ago

Try latest Windows snapshot, which I just updated and see if
that solves issue.

comment:2 by SF/logicdeluxe, 16 years ago

Sounds a lot better already. However it still sounds
slightly different, mostly noticable in the Indy3 intro, but
don't ask which one is closer to the original, since I have
no native OPL chip right now to compare. Sounds fine to me
the way it is now. The SB-Live, I'm using at the moment, has
a very poor Adlib emulation.

comment:3 by Kirben, 16 years ago

Owner: set to Kirben
Resolution: fixed
Status: newclosed

comment:4 by Kirben, 16 years ago

Some of the intruments in old bundle games
(indy3/monkeyega/monkeyvga) music were incorrect before,
which was recently fixed. The indy3 music under ScummVM
should sound exactly like the original music now.

comment:5 by digitall, 13 months ago

Component: --Unset--Engine: SCUMM
Game: Indiana Jones 3
Note: See TracTickets for help on using tickets.