Opened 13 months ago

Closed 13 months ago

Last modified 13 months ago

#11163 closed defect (fixed)

SCI: Hoyle 4 - Invalid arithmetic operation

Reported by: misterhands Owned by:
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: Hoyle's Classic Card Games

Description

Hoyle 4 DOS

During a game of Bridge:

Invalid arithmetic operation (bitwise OR - params: 0026:00db and 0000:0f00) from method Declarer_Second_NT::think (room 700, script 733, localCall ffffffff)!

Change History (5)

comment:1 by bluegr, 13 months ago

Owner: set to bluegr
Resolution: duplicate
Status: newclosed

This refers to Hoyle 5, and is a duplicate of bug #11173. Closing

comment:2 by misterhands, 13 months ago

This does occur in Hoyle 4 as well...

comment:3 by sluicebox, 13 months ago

Resolution: duplicate
Status: closednew

It's Hoyle4 too, both games have the same script for making decisions.

I can finally reproduce this (I don't know how to play Bridge!) and have patches for 4 and 5; I'll get them written up and committed tomorrow.

comment:4 by sluicebox, 13 months ago

Owner: bluegr removed
Resolution: fixed
Status: newclosed

comment:5 by sluicebox <22204938+sluicebox@…>, 13 months ago

In c7e9b182:

SCI: Fix HOLYE4 and HOLYE5 Bridge invalid arithmetic

Fixes bugs #11163 and #11173. Both games contain the same buggy script.

Note: See TracTickets for help on using tickets.