#11162 closed defect (fixed)

SCI: Hoyle 4 Uninitialized read

Reported by: misterhands Owned by: bluegr
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: Hoyle's Classic Card Games

Description

Hoyle 4 DOS

During a game of Bridge:
Uninitialized read for temp 2 from method LeadReturn_NoTrump::makeContractMinusAce (room 700, script 752, localCall ffffffff)!

Change History (6)

comment:1 by bluegr, 13 months ago

Owner: set to bluegr
Resolution: duplicate
Status: newclosed

This refers to Hoyle 5, and is a duplicate of bug #11172. Closing

comment:2 by misterhands, 13 months ago

Nope this is really a Hoyle 4 bug. Please reopen.

comment:3 by bluegr, 13 months ago

Resolution: duplicate
Status: closednew

comment:4 by Filippos Karapetis <bluegr@…>, 13 months ago

In f2079e9a:

SCI32/SCI: Sync Hoyle 4 and Hoyle 5 Bridge workarounds

These two games use the same scripts for the Bridge sub-game, so their
workarounds are the same. Fixes bugs #11162, #11183

comment:5 by Filippos Karapetis <bluegr@…>, 13 months ago

In 41a0b3c:

SCI32/SCI: Sync Hoyle 4 and Hoyle 5 Bridge workarounds

These two games use the same scripts for the Bridge sub-game, so their
workarounds are the same. Fixes bugs #11162, #11183

comment:6 by bluegr, 13 months ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.