Opened 7 weeks ago

Closed 4 weeks ago

#11140 closed defect (fixed)

HDB: Game crashes at a certain point in Servandrones Inc (Level 2 )

Reported by: TofuTitan Owned by: TofuTitan
Priority: normal Component: Engine: HDB
Keywords: Hyperspace Delivery Boy Audio Crash Cc:
Game:

Description (last modified by TofuTitan)

ScummVM Version: ScummVM 2.1.0git8141-g541689eeb2
Game Version: Windows
Game Language: English
OS: Antergos Linux

Bug Description:

The crash always happened at the same exact spot in the second level. Seems to be an audio error according to the Terminal output. Screenshot and Terminal output are in the Attachments.

Attachments (2)

Screenshot_20190905_184733.png (158.8 KB ) - added by TofuTitan 7 weeks ago.
scummvm.txt (2.4 KB ) - added by TofuTitan 7 weeks ago.
Terminal Output

Download all attachments as: .zip

Change History (11)

by TofuTitan, 7 weeks ago

by TofuTitan, 7 weeks ago

Attachment: scummvm.txt added

Terminal Output

comment:1 by TofuTitan, 7 weeks ago

Description: modified (diff)

in reply to:  description comment:2 by NML32, 5 weeks ago

Replying to TofuTitan:

ScummVM Version: ScummVM 2.1.0git8141-g541689eeb2
Game Version: Windows
Game Language: English
OS: Antergos Linux

Bug Description:

The crash always happened at the same exact spot in the second level. Seems to be an audio error according to the Terminal output. Screenshot and Terminal output are in the Attachments.

ScummVM 2.1.0git8384-g52166aa3b1 (Sep 19 2019 20:01:25)
This also happens to me on the second level on the upper left portion of the map while collecting diamonds.

Last edited 5 weeks ago by NML32 (previous) (diff)

comment:3 by sev-, 5 weeks ago

Could you please provide md5 of your hyperspace.mpc file? It is obviously corrupt. Try to recopy from the media.

comment:4 by sev-, 5 weeks ago

In the meantime I implemented a guard check, please recompile and retest.

Some of the pirated versions from the internets have sound data removed from the game archive. If it is your case, well, we cannot do anything with it.

comment:5 by NML32, 5 weeks ago

MD5 of hyperspace.mpc fa5a756024ff91ca405274c1aef13759

comment:6 by sev-, 5 weeks ago

Right, the correct md5 is f6efce6d337b40008daaf5e8fe428c5e, and the file length is 50339161. Your file is corrupted.

comment:7 by TofuTitan, 5 weeks ago

Just tested it with the latest commit and it doesn't crash anymore in that part of Level 2. I also checked the md5 and file length of my sound data and it matches.

comment:8 by NML32, 5 weeks ago

I can confirm with the guard check no more crashes on level 2.
Thank you.

comment:9 by TofuTitan, 4 weeks ago

Owner: set to TofuTitan
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.