Opened 2 months ago

Closed 2 months ago

#11138 closed defect (fixed)

Blade Runner: Unable to buy bracelet

Reported by: JoesGuy Owned by: antoniou79
Priority: normal Component: Engine: Bladerunner
Keywords: Bracelet Cc:
Game: Blade Runner with restored content

Description

ScummVM: 2.1.0git-6893

In Act 2 on Animoid Row, I don't seem to be able to buy the bracelet from the Peruvian insect women despite having the funds for it. Even with user choice dialogue option, it automatically goes through with the option of not having enough money. Also tried Easy mode with infinite money, same issue.

Change History (4)

comment:1 by antoniou79, 2 months ago

Owner: set to antoniou79
Resolution: fixed
Status: newpending

Good catch. This is a side effect of the recent restored content -- which have to be tested a bit more. But this specific bug should be fixed with the current commit:
https://github.com/scummvm/scummvm/commit/dde41f1432f236a5a09a16299cf2e84e47f2274b

Otherwise, we will need a save game file to reproduce the issue.

comment:2 by antoniou79, 2 months ago

I'll be closing this ticket by Sunday, if there's no further feedback about whether the issue persists.
I've tested a few times after the fix and for me it works as intended.

comment:3 by JoesGuy, 2 months ago

Yep, all fixed on my end, even using the same old save.

comment:4 by antoniou79, 2 months ago

Status: pendingclosed
Note: See TracTickets for help on using tickets.