Opened 3 months ago

Closed 4 weeks ago

#11118 closed defect (fixed)

Screenshot grabber bug

Reported by: e-Scarlatti Owned by: sluicebox
Priority: normal Component: Port: Win32
Keywords: Cc:
Game:

Description

Windows 10 build 1803 64-bit

ScummVM 2.1.0git6767-g05de8819ba (Aug 30 2019 14:25:33)

By default, the ALT+S screenshot grabber writes sequential images to the "ScummVM Screenshots" folder inside the Windows "Pictures" folder.

However, when I try to get several screenshots this way, the same shot ("scummvm000.png") keeps being overwritten by ScummVM.

After being unable to get new screenshots, I edited the scummvm.ini file and added the screenshotpath variable, pointing it to a normal folder like "C:\Games\Screenshots\". The screenshot function then started to behave correctly, taking several shots in sequence instead of overwriting the same file.

I'm guessing here, but maybe the problem is related to my Windows profile name, "Leviatã". If you can't see the last character, it is an "a" with a tilde "~", very common in the Portuguese language. The default pictures folder path includes the profile name, something like "C:\Users\Leviatã\Pictures". Is it an Unicode character, perhaps ?

Change History (3)

comment:1 by digitall, 3 months ago

Component: ScreenshotsPort: Win32

comment:2 by sluicebox, 4 weeks ago

Thanks for reporting this. Nice job troubleshooting!

The unicode character is indeed the relevant factor and I reproduced this.

https://github.com/scummvm/scummvm/pull/1926

comment:3 by bluegr, 4 weeks ago

Owner: set to sluicebox
Resolution: fixed
Status: newclosed

The pull request has been merged, so this bug should be fixed in the next daily version

Note: See TracTickets for help on using tickets.