Opened 2 months ago

Closed 2 months ago

#11081 closed defect (fixed)

SCI: ECO2: Icon bar crashes during tutorial

Reported by: sluicebox Owned by: sluicebox
Priority: normal Component: Engine: SCI
Keywords: original Cc:
Game: EcoQuest 2

Description

Clicking any icon during the icon bar tutorial in the first room crashes. This is a script bug that happened to work due to memory layout in the original.

To reproduce with attached save, click an icon.

Attachments (1)

ecoquest2.002 (35.7 KB ) - added by sluicebox 2 months ago.

Download all attachments as: .zip

Change History (3)

by sluicebox, 2 months ago

Attachment: ecoquest2.002 added

comment:1 by sluicebox <22204938+sluicebox@…>, 2 months ago

In 25374e05:

SCI: Fix ECO2 Icon bar tutorial

Fixes bug #11081

comment:2 by sluicebox, 2 months ago

Owner: set to sluicebox
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.