Opened 3 months ago

Closed 3 months ago

Last modified 5 weeks ago

#11066 closed defect (wontfix)

XEEN: Limited-use objects (potions etc.) don't work as intended

Reported by: darkstar Owned by: dreammaster
Priority: normal Component: Engine: Xeen
Keywords: Cc:
Game: Might and Magic: World of Xeen

Description

Items like potions (maybe others), that can be used only a limited amount of time and then disappear, have their usage count reduced even if the player cancels the "who will use" question.

Example: the potions in the temple of bark (see attached savegame)

Load savegame, click on the potion and then press "cancel" instead of selecting a char. Repeat 3 times and the potion is gone

Attachments (1)

worldofxeen.009 (219.9 KB ) - added by darkstar 3 months ago.
savegame

Download all attachments as: .zip

Change History (4)

by darkstar, 3 months ago

Attachment: worldofxeen.009 added

savegame

comment:1 by dreammaster, 3 months ago

Owner: set to dreammaster
Resolution: wontfix
Status: newclosed

I double-checked, and this is an original game bug due to a poorly written script. It might in theory be possible to fix by juggling around the instructions on the associate script(s), but for now I'm going to close this as a won't fix, and leave a note in a new "Original Bugs" section in the Wiki engine page

comment:2 by dreammaster, 3 months ago

For reference, the script is slightly complicated and uses self-modification of it's own code to implement the "number of times used" counter. So doing a script patch would involve having to patch multiple lines in, likely, every single copy of the script for each different item. Given that, it's more trouble than it's worth trying to fix it for now.

comment:3 by Thunderforge, 5 weeks ago

Game: Might and Magic: World of Xeen
Note: See TracTickets for help on using tickets.