Opened 3 months ago

Closed 3 months ago

Last modified 5 weeks ago

#11063 closed defect (fixed)

XEEN: Redraw issues on the "Misc" inventory screen

Reported by: darkstar Owned by: dreammaster
Priority: normal Component: Engine: Xeen
Keywords: Cc:
Game: Might and Magic: World of Xeen

Description

When moving a "misc" item from character A to character B, if character B's Misc-inventory was empty before, the item's name will be printed over the "Nothing available" display.

See screenshot

Attachments (2)

screen01.png (138.9 KB ) - added by darkstar 3 months ago.
worldofxeen.006 (219.2 KB ) - added by darkstar 3 months ago.
savegame showing the issue. Check inventory of character #1

Download all attachments as: .zip

Change History (5)

by darkstar, 3 months ago

Attachment: screen01.png added

by darkstar, 3 months ago

Attachment: worldofxeen.006 added

savegame showing the issue. Check inventory of character #1

comment:1 by dreammaster, 3 months ago

Owner: set to dreammaster
Resolution: worksforme
Status: newpending

Interesting glitch. It seems like the first two slots of your first character are corrupted.. they have an item associated with an item, but not a material. Which is why it shows the valid items with a "3)" and "4)" prefix, but also incorrectly shows the "nothing" text. Unfortunately, I've tried various other savegames of mine, trying to shift misc items between characters, but couldn't replicate the issue. Maybe you'll be able to with an earlier savegame yourself.. if you can re-replicate the problem from scratch, I could use a savegame from before the problem first appears.

comment:2 by dreammaster, 3 months ago

Resolution: worksformefixed
Status: pendingclosed

In closing one of the other tickets, I've located how misc items can be created with no material specified. This was the cause of the bad entries in the misc inventory causing the redraw issues.

comment:3 by Thunderforge, 5 weeks ago

Game: Might and Magic: World of Xeen
Note: See TracTickets for help on using tickets.