Opened 3 months ago

Closed 2 months ago

Last modified 2 months ago

#11059 closed defect (fixed)

XEEN: Wrong sound effect in Winterkill when shooting monsters

Reported by: darkstar Owned by: dreammaster
Priority: normal Component: Engine: Xeen
Keywords: Cc:
Game: Might and Magic: World of Xeen

Description

When shooting the skeletons in Winterkill with ranged weapons and missing, the "swish" sound of missing with a close-combat weapons is played. Everywhere else, missing with ranged weapons produces no sound at all.

Savegame attached

Attachments (1)

worldofxeen.005 (218.2 KB ) - added by darkstar 3 months ago.
savegame

Download all attachments as: .zip

Change History (6)

by darkstar, 3 months ago

Attachment: worldofxeen.005 added

savegame

comment:1 by darkstar, 3 months ago

Also, all those enemies should have some sort of see-through look, as seen here:

https://www.youtube.com/watch?v=3VAlrxesFZs

comment:2 by dreammaster, 2 months ago

For the sound effects at least, it seems like the engine is working as designed. Based on my understanding of the combat code, the game differentiates between arrows missing and arrows hitting but doing no damage due to physical resistances. You can see this easily.. if you start a fresh game and go directly to Dark Side and out to the countryside, there's a higher probability of your arrows missing due to your low level. You'll hear no sound effect. Whereas for the Winterkill skeletons, you're hitting them but they have resistance to physical weapons, so your attack connects but does no damage. Hence the sound effect there.

comment:3 by dreammaster, 2 months ago

As for the transparency, I finally figured it out. The original had very messy drawing code, with about a dozen different versions of drawing code handling different combinations of resizing, flipping, etc. Honestly, in the end it was easier just to throw the bulk of it out and create my own drawing routine that had everything combined. But it seems I overlooked the multiple (yes multiple) routines for drawing sprites semi-transparently. Hopefully the variations are just something simple like the degree of transparency, and I can fold them all into my existing draw method

comment:4 by dreammaster, 2 months ago

Owner: set to dreammaster
Resolution: fixed
Status: newclosed

And I've now implemented the transparency drawing code. I also put in a fix to work around the original showing a bunch of black pixels when drawing the shades as transparent

comment:5 by darkstar, 2 months ago

Whereas for the Winterkill skeletons, you're hitting them but they have resistance to physical weapons, so your attack connects but does no damage. Hence the sound effect there.

Yes, but it's not the "hit" sound that is getting played, but the "miss" sound...? I'm confused. YouTube seems to agree with you that this is how the original played out though, so I think we can leave it at that...

Note: See TracTickets for help on using tickets.