Opened 3 months ago

Closed 2 months ago

#11056 closed defect (fixed)

QFG4: Necrotaurs chasing you outside town after the dungeon sequence

Reported by: lwcorp Owned by: sluicebox
Priority: normal Component: Engine: SCI
Keywords: original Cc:
Game: Quest for Glory 4

Description

Necrotaurs are supposed to chase you after you meet a certain character south to the castle. However, they also chase you just outside town after the dungeon sequence.

If you let them catch you, ScummVM gets stuck with a bug message.

If you go back to town and then go outside, suddenly they're gone and you can continue playing.

Attachments (2)

version.png (1.7 KB ) - added by lwcorp 3 months ago.
qfg4-cd.002 (93.4 KB ) - added by lwcorp 3 months ago.

Download all attachments as: .zip

Change History (9)

by lwcorp, 3 months ago

Attachment: version.png added

by lwcorp, 3 months ago

Attachment: qfg4-cd.002 added

comment:1 by lwcorp, 3 months ago

Component: --Unset--Port: Win64
Game: Quest for Glory 4

comment:2 by lwcorp, 3 months ago

As a matter of fact, if you let them catch you outside the town's gate (and not in the forest) then you get taken into the dungeon sequence again.
In other words, you can play that sequence till infinity.

comment:3 by digitall, 3 months ago

Component: Port: Win64Engine: SCI

comment:4 by sluicebox, 3 months ago

Keywords: original added

That's funny, a while back I was trying to make sense of the flags that control this sequence and I made a note like "I don't think this would work?"

What's the error message you get? Can you attach a screenshot of it, and where you get stuck? I used your save game and walked south one screen to the town gate, waited until I got caught, but it just took me back to the dungeon, like you described in your update. How do I get it stuck? (There might be two bugs here)

comment:5 by sluicebox, 3 months ago

Never mind, I can now reproduce the kUpdateScreenItem error too.

I have a fix that looks promising so far, but I'll need to do a bit of testing against all the versions, since this bug is in each. Great catch!

comment:6 by sluicebox <22204938+sluicebox@…>, 2 months ago

In 49914254:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:7 by sluicebox, 2 months ago

Owner: set to sluicebox
Resolution: fixed
Status: newclosed

Wow, this uncovered three unrelated script bugs in the original game:

  1. The chase repeating (under many circumstances)
  2. Game randomly crashes after the screen goes black when the necrotaurs catch you in the woods
  3. Game randomly crashes as soon as a necrotaur reaches you (CD version only)

To be clear, the first bug is just that the chase can reoccur after you've been caught. You don't have to reach Ad Avis in front of the castle, triggering the chase from the town gate (where he can catch you right there) is a normal alternative.

Note: See TracTickets for help on using tickets.