Opened 4 months ago

Closed 2 months ago

Last modified 2 months ago

#11045 closed defect (duplicate)

QFG4: castle doors don't seem to get oiled

Reported by: lwcorp Owned by:
Priority: low Component: Engine: SCI
Keywords: original Cc:
Game: Quest for Glory 4

Description (last modified by lwcorp)

Possibly related to #10832 (which was submitted before the game was supported in beta), the castle doors all squeak and complain about sound (e.g. the hallway) even though I've oiled them all.

Attachments (3)

version.png (1.7 KB ) - added by lwcorp 4 months ago.
qfg4-cd.003 (71.1 KB ) - added by lwcorp 2 months ago.
Savegame with and without oiling the hallway door
version new.png (2.9 KB ) - added by lwcorp 2 months ago.
Stable daily build

Download all attachments as: .zip

Change History (12)

by lwcorp, 4 months ago

Attachment: version.png added

comment:1 by lwcorp, 3 months ago

Summary: QF4: castle doors don't seem to get oiledQFG4: castle doors don't seem to get oiled

comment:2 by digitall, 3 months ago

Component: Port: Win64Engine: SCI

comment:3 by sluicebox, 3 months ago

Can you please attach a save game for this?

There are a lot of castle rooms and I'm not sure which one you mean by hallway, or which door. Could you include the relevant room numbers in your description? To find that out, bring up the ScummVM debugger by pressing CTRL + SHIFT + D. Then type "room" and hit enter, it will print the room number. You can dismiss the debugger by pressing ESC or with the "exit" command.

I find the door oiling confusing in this game because the normal sound effect the castle doors make when opening sounds squeaky to me, even though I think they were just trying to make them sound big and old. Separate from that, there are several castle door oiling bus, but it's tricky to figure out which is which.

I didn't see your bug report until today, but two weeks ago I fixed a nest of bugs (including oiling) surrounding the east door from The Great Hall. Maybe that's the hallway you were referring to, so please try the latest nightly build and see if that made a difference.

comment:4 by sluicebox, 2 months ago

Keywords: original added
Priority: normallow

by lwcorp, 2 months ago

Attachment: qfg4-cd.003 added

Savegame with and without oiling the hallway door

by lwcorp, 2 months ago

Attachment: version new.png added

Stable daily build

comment:5 by lwcorp, 2 months ago

It's room 627, which is a staircase leading to the hallway aka "castle lobby".
If it's the first time you open that door at night without oil, it's game over.
I've just attached a savegame in which you stand right next to the relevant door with oil as your active inventory.
Try opening the door with and without oiling it.
If you use the version I used when opening this ticket (it was the latest 64-bit development build of that time and attached as a screenshot), you'll see you get a warning about the door being noisy even if you did oil it. Luckily, if you did oil it the warning is just fake.

However...the warning seems to be fixed in the new daily 64-bit stable build, which I've just downloaded (and put a version screenshot here) due to the request of https://www.scummvm.org/news/20190917/. It's probably related to your fixes.

Nevertheless, while the noisy door warnings seem to have gotten fixed, the annoying squeaky sound is still heard in every single castle door whether you oiled it or not. So only half the bug was solved. I think it's only natural that oiling the doors should stop the squeaking itself and not just the warnings about squeaking.

The link in the ticket's description seems to suggest doors can be opened without a squeaky sound if they're oiled.

Last edited 2 months ago by lwcorp (previous) (diff)

comment:6 by lwcorp, 2 months ago

Description: modified (diff)

comment:7 by sluicebox, 2 months ago

Thanks for the saved game. Yes, I am *very* familiar with room 627... aab22041310e343f0c809b3e7f647cbc5550a625

One of the bugs I fixed in that commit was the incorrect message about the door squeaking even if you'd oiled it. That bug, along with the others, are all specific to the top door in room 627. Those are the only castle door fixes that have been done since you reported the issue so what you're saying is what I'd expect; only room 627 is different from when you tested.

I'll take a look at the general door oiling soon and see what's going on. I do know that the behavior is the same as it was in the original game, even if it doesn't make sense.

comment:8 by sluicebox, 2 months ago

Resolution: duplicate
Status: newclosed

I'm afraid this is just a confusing part of the game.

This is unrelated to #10832, in which six rooms have bugs where picking the lock will treat the door as oiled if any of the room's other doors were oiled.

If a door is squeaky, then opening it should play a squeak sound and say a message about the squeak. If it's not squeaky, or if you oiled it, then there should be no squeak sound and no message. Unfortunately, that's exactly what the game is doing, even though the results are confusing.

There are two sounds: a door-open sound (audio 972) and a squeak sound (audio 143). If a door squeaks then the script says the message and plays the squeak sound and plays the door-open sound. The door-open sound always plays. They're named doorSound and squeakSound in scripts.

Problems:

  • The door-open sound (audio 972) sounds squeaky
  • The scripts play both sounds at the same time
  • The door-open sound is much louder than the squeak sound
  • The narrator talks over the squeaking in some rooms (three sounds at once)

The result is that the squeak sound usually (always?) has no audible effect, meanwhile opening any castle door sounds squeaky, because that's just the sound. I reconfirmed in dosbox that this is how it all behaved in the original.

I'm closing this since the fixable bug (room 627 message) has been fixed and this is the original behavior. I don't see any feasible way to make the doors not sound the way they are, and even if I did I suspect it would cross the line into changing the game. It doesn't help that almost every door is implemented differently in its own room with its own inconsistencies. There are 20+ squeak paths. This seems like an ambitious feature that just didn't come together.

I've written this up in detail because I have a feeling we'll need to reference it again...

comment:9 by lwcorp, 2 months ago

Description: modified (diff)
Note: See TracTickets for help on using tickets.