Opened 3 weeks ago

Closed 10 days ago

Last modified 10 days ago

#11041 closed defect (worksforme)

pack_bladerunner doesn't actually write HDFRAMES.DAT to disk

Reported by: theruler Owned by: antoniou79
Priority: normal Component: Tools
Keywords: tools Cc:
Game: Blade Runner

Description

d:\_ScummVM\tools>scummvm-tools-cli --version
ScummVM Tools 2.1.0git (Aug 1 2019 09:36:12)

d:\_ScummVM\tools>scummvm-tools-cli --tool pack_bladerunner ./cdframes1.dat
Warning: Could not find file CDFRAMES
Warning: Retrying for file CDFRAMES1
Reading 536 pages from CDFRAMES1.DAT...
Reading 1789 pages from CDFRAMES2.DAT...
Reading 1691 pages from CDFRAMES3.DAT...
Reading 1332 pages from CDFRAMES4.DAT...
All done!
File is created in ./HDFRAMES.DAT

d:\_ScummVM\tools>

But there are no HDFRAMES.DAT anywhere.

Change History (5)

comment:1 in reply to:  description Changed 3 weeks ago by antoniou79

Replying to theruler:

All done!
File is created in ./HDFRAMES.DAT

But there are no HDFRAMES.DAT anywhere.

Hello,
I cannot reproduce your issue. With your command the HDFRAMES.DAT will be created as the message suggests in the current folder which in your case is "d:\_ScummVM\tools"

comment:2 Changed 3 weeks ago by antoniou79

Owner: set to antoniou79

comment:3 Changed 3 weeks ago by antoniou79

Resolution: worksforme
Status: newpending

comment:4 Changed 13 days ago by antoniou79

@theruler, could you please provide an update if the issue persists for you?

If there's no new feedback this ticket will be closed by the end of the week.

comment:5 Changed 10 days ago by antoniou79

Status: pendingclosed

I am closing this, as there's no new feedback and the pack_bladerunner tool seems to be working fine I looked through the code again and tested it a few times with different paths and cases and there was no outstanding related bug.

One thing I haven't tested, and I am unsure if it could be the reason for this ticket, is maybe there was not enough free space on the hdd to write the resulting file.

Last edited 10 days ago by antoniou79 (previous) (diff)
Note: See TracTickets for help on using tickets.