Opened 3 weeks ago

Closed 2 weeks ago

Last modified 2 weeks ago

#11037 closed defect (wontfix)

iOS crash on digital audio in Simon the Sorcerer

Reported by: TheQL Owned by: criezy
Priority: normal Component: Port: iOS
Keywords: Cc:
Game: Simon the Sorcerer 1

Description

Simon the Sorcerer (CD/Windows/German) seems to crash when digital audio is played. So directly in the intro when the table/candle reaches Simon, boom, dead.
Tried with several (own) builds, all >= 2.1.git from 20190715 and newer.

Change History (6)

comment:1 Changed 3 weeks ago by criezy

Do you have any specific audio settings set?

I don't have the German version, but with the English Windows CD version and all the settings kept to default it plays the full intro without a crash for me. When the table/candle reaches Simon he starts speaking normally.

comment:2 Changed 2 weeks ago by criezy

I forgot that I had compressed the audio to ogg (using our compress_agos tool) and that I was using the music from James Woodcock's music enhancement project. So I tried again with the original files copied from the CD and I still cannot reproduce any issue.

Are you using the original files, or did you compress the audio? If you did, to which format?

comment:3 Changed 2 weeks ago by TheQL

Hi!
No special audio settings, at least not regarding digital audio. I have enabled MT32 though.

There is no issue on Mac with the audio. I actually got it from a German abandonware site, audio is SIMON.mp3. compressed with 40kbit/s. Not really sure if that's the original format, as it's not WAV, maybe not. But the mp3 seems fine and only causes trouble on iOS.
Maybe I just need to get the original version, if so, sorry for causing trouble. I could supply the .mp3 or give you the link source I used, manually converting my .mp3 to .ogg just caused Simon to remain silent.

comment:4 Changed 2 weeks ago by TheQL

Hi, your info about the ScummVM tools helped me out, I think. First of all I got a version from archive.org, that contained the original .voc - this just works.

I looked into the tools and found it had the option to select PC/Mac or iPhone as target when compressing audio. Not sure why, but this sure sounds interesting. Anyway, I compressed the .voc to .ogg using PC/Mac as target and it works on my iPhone now. Even when adding the enhanced music, great tip, btw.!

So, not sure what to say. Somehow my .mp3 seems to have issues with iOS, but not sure if it's worth to investigate further.

comment:5 Changed 2 weeks ago by criezy

Owner: set to criezy
Resolution: wontfix
Status: newclosed

As a policy we don't support pirated copies of games (see https://wiki.scummvm.org/index.php?title=Copyright_FAQ). And the Simon the Sorcerer games are still available to buy (for example on GoG.com).

So closing this as wontfix (although I might compress my original copy to MP3 to check if that one also causes an issue).

comment:6 Changed 2 weeks ago by TheQL

It's on archive.org, shouldn't be pirated then, right? Anyway, thanks for your input, it helped!

Note: See TracTickets for help on using tickets.