Opened 4 months ago

Closed 2 months ago

#11036 closed defect (fixed)

iOS issue "Could not initialize color format." on starting Blade Runner and Gabriel Knight

Reported by: TheQL Owned by: peterkohaut
Priority: normal Component: Port: iOS
Keywords: Cc: ccawley2011
Game: Blade Runner

Description

Both games, but probably others, show this error and then only show defective or no graphic. Gabriel Knight actually looks fine but shows on each scene change.

Tested with my own 64-Bit build on iOS12 from 20190730. Also included https://github.com/scummvm/scummvm/pull/1766 to no avail.

Change History (9)

comment:1 by ccawley2011, 3 months ago

Cc: ccawley2011 added

Blade Runner should hopefully be fixed by https://github.com/scummvm/scummvm/pull/1825

Regarding Gabriel Knight, does it make a difference if you unset the "Use high-quality video scaling" option in the Engine tab of the Edit Game dialog?

comment:2 by TheQL, 3 months ago

Blade Runner seems fixed. Regarding Gabriel Knight I am confused. It works without error, but it seems to skip the entire intro video where the error occured: https://www.youtube.com/watch?v=BWdmmu91jGY

This is also true right now for an older build that had the error before, so I cannot reproduce at the moment. Will try to figure this out.

comment:3 by TheQL, 3 months ago

Ok, no idea what just went wrong, now the error is back. But it indeed disappears when unsetting "Use high-quality video scaling".

Last edited 3 months ago by TheQL (previous) (diff)

comment:4 by peterkohaut, 3 months ago

i had to rework that patch to add support more pixel format, now the best one on every platform should be used (doesnt have to be 16bit format). Please, can you retest with https://github.com/scummvm/scummvm/commit/a7399c5111cc7ebeea284498a1ee5ac7542bb96d ?

comment:5 by TheQL, 3 months ago

I had a merging conflict after I pulled and cherry-picked this commit. Something with engines/bladerunner/outtake.cpp, but I don't quite get it... Sorry... I feel a little more comfortable using PRs, maybe I am just too stupid to use git correctly to fetch this commit...

comment:6 by ccawley2011, 3 months ago

The commit mentioned has already been merged in, so it should be sufficient to just build from a clean working copy.

comment:7 by TheQL, 3 months ago

That could explain why I had a conflict... Will make a clean build and report back.

comment:8 by TheQL, 3 months ago

Built from fresh pull at commit e376abf650137c0d4dfa0f424f3a035813e3f618 (HEAD -> master, origin/master, origin/HEAD).

Works!

comment:9 by antoniou79, 2 months ago

Owner: set to peterkohaut
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.