Opened 4 months ago

Closed 3 months ago

#11023 closed defect (duplicate)

QFG4: Colorful glitch when going left from town

Reported by: lwcorp Owned by: sluicebox
Priority: low Component: Engine: SCI
Keywords: Cc:
Game: Quest for Glory 4

Description

When walking left from the town to the direction of the castle, there's a colorful glitch in the right side of the screen. It remains until you leave into a new screen.

Attachments (2)

colorful.png (72.9 KB ) - added by lwcorp 4 months ago.
version.png (1.7 KB ) - added by lwcorp 4 months ago.

Download all attachments as: .zip

Change History (8)

by lwcorp, 4 months ago

Attachment: colorful.png added

by lwcorp, 4 months ago

Attachment: version.png added

comment:1 by dafioram, 4 months ago

Priority: normallow
Summary: Colorful glitch when going left from townQ4G: Colorful glitch when going left from town

Hi, I see you put the win64 port did you get that from the build bot or make it yourself? The scummvm binary on the download page is win32.

Any idea if it happens in dosbox also?

comment:2 by angstsmurf, 4 months ago

This seems very similar to #10748, which turned out to occur in the original interpreter as well.

comment:3 by dafioram, 4 months ago

Summary: Q4G: Colorful glitch when going left from townQFG4: Colorful glitch when going left from town

in reply to:  1 comment:4 by lwcorp, 4 months ago

Replying to dafioram:

Hi, I see you put the win64 port did you get that from the build bot or make it yourself? The scummvm binary on the download page is win32.

I've just used "Windows (64bit)" from https://buildbot.scummvm.org/builds.html

Any idea if it happens in dosbox also?

Just checked (v0.74-3) and it doesn't happen there.

comment:5 by digitall, 3 months ago

Component: Port: Win64Engine: SCI

comment:6 by sluicebox, 3 months ago

Owner: set to sluicebox
Resolution: duplicate
Status: newclosed

This is indeed a duplicate of #10748, which I fixed in the time since this ticket was opened. (I didn't notice this ticket until today.)

This was a ScummVM graphics bug, not a bug in the original game or original interpreter.

Good eye, and that makes at least three of us obsessives that independently noticed a subtle column of incorrect edge pixels on a dozen or so busy screens.

Note: See TracTickets for help on using tickets.