Opened 5 weeks ago

Closed 4 weeks ago

#11021 closed defect (fixed)

COMPOSER: Gregory and the Hot Air Ballon: Unable to unload library errors

Reported by: angstsmurf Owned by: angstsmurf
Priority: normal Component: Engine: Composer
Keywords: Cc:
Game:

Description

User danish reports on IRC:

[17:17] <danish> On the off chance someone reads this who can submit a bug report, apologies I've been trying but can't get my github account to authorize for some reason. There is a game breaking bug/bugs for Gregory and the Hot Air Ballon (both english and french) as of 2.0. I've tested latest daylies and it doesn't work. The game works fine in 1.9. (Both Ubuntu
[17:17] <danish> and Debian builds) The errors state "unable to unload library 29" and "archive does not contain 'ANIM' 2715." The second error is easily re-creatable by clicking the carnival ticket in your inventory. I have included the saves and a screenshot in the following links:https://i.imgur.com/oNXk23s.png https://files.catbox.moe/h7aaxp.zip
[17:22] <danish> Again, sorry for the imposition and thank you to anyone who can help.

This is actually at least two different bug reports, where the second one ("archive does not contain 'ANIM' 2715.") seems to be fixed by commit e45dd70. I only have the Mac version of Gregory, but the save file format seems to be cross-platform and works after renaming the file. I could not reproduce the exact error described, but I got a similar message ("tried to unload library 39, which isn't loaded!") by spamming Escape on the screen that opens when clicking on the todo-list.

Change History (4)

comment:1 Changed 5 weeks ago by angstsmurf

Changing this error into a warning at least keeps the game going. See pull request #1756.

comment:2 Changed 5 weeks ago by angstsmurf

This turns out not to be a regression, as it already occurs in ScummVM 1.5.0, where the Composer engine was introduced. To trigger it, just play until Gregory writes his todo-list (after crashing the balloon), click on the todo-list and then spam Escape.

comment:3 Changed 4 weeks ago by Filippos Karapetis <bluegr@…>

In 324d488d:

COMPOSER: Change unload library error to warning

This fixes Gregory and the Hot Air Balloon. See tracker #11021.

comment:4 Changed 4 weeks ago by bluegr

Owner: set to angstsmurf
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.