Opened 19 months ago

Closed 5 months ago

Last modified 5 months ago

#10993 closed defect (fixed)

ZVISION: Font rendering regression

Reported by: bgK Owned by: bluegr
Priority: high Component: Engine: ZVision
Version: Keywords:
Cc: Game: Zork Grand Inquisitor

Description

Revision b87f69827c84715738a8aea5af35c792da9c1d59.

The ZVision engine was changed to load fonts from fonts.dat. However not all the required fonts were included. As a result, the engine uses fallback fonts in some places.

For example, in ZGI, in the help menu accessible from the main menu, only the first line of the text is supposed to be in bold. See the attached screenshots.

Attachments (3)

Screenshot from 2019-06-22 15-40-34.png (133.9 KB ) - added by bgK 19 months ago.
Screenshot from 2019-06-22 15-39-43.png (133.6 KB ) - added by bgK 19 months ago.
2.0.0
Screenshot from 2019-06-22 15-40-34.2.png (133.9 KB ) - added by bgK 19 months ago.
master

Download all attachments as: .zip

Change History (6)

comment:1 by sev-, 5 months ago

Priority: normalhigh

comment:2 by bluegr, 5 months ago

Owner: set to bluegr
Resolution: fixed
Status: newclosed

comment:3 by eriktorbjorn, 5 months ago

I guess that's just a matter of adding FreeMono.ttf to the fonts.dat file? Currently it only has FreeMonoBold.ttf, FreeSans.ttf and FreeSansBold.ttf.

(I didn't notice this when I played through ZGI recently because I still had the fonts as separate files outside of fonts.dat.)

Edit: Ooops, too slow :-)

Last edited 5 months ago by eriktorbjorn (previous) (diff)
Note: See TracTickets for help on using tickets.