Opened 5 months ago

Closed 4 months ago

#10985 closed defect (fixed)

Machine gun disappears at Bullet Bob's

Reported by: Surt-R Owned by: antoniou79
Priority: normal Component: Engine: Bladerunner
Keywords: Cc:
Game: Blade Runner

Description

Sometimes the machine gun disappears after looking at it. Not sure if this bug was present in the original game. See image attached.

Attachments (2)

brbug.png (443.8 KB ) - added by Surt-R 5 months ago.
bladerunner-win.008 (32.0 KB ) - added by tentaclemoose 5 months ago.

Download all attachments as: .zip

Change History (10)

by Surt-R, 5 months ago

Attachment: brbug.png added

comment:1 by peterkohaut, 5 months ago

So far I was unable to reproduce this. Please, if it happens next time, can you open debug console with CTRL+D and enter commands "goal 67" and then "pos 67" and give us the output?

comment:2 by Surt-R, 5 months ago

No problem. It appears to be a rare issue.

comment:3 by tentaclemoose, 5 months ago

I've just run into this bug on latest build (2.1.0git5835-g2287a4f607)

goal 67:
actorGoal(67) = 0

pos 67:
actorSet(67) = 98
actorX(67) = -680.000000
actorY(67) = 0.000000
actorZ(67) = -156.000000
actorFacing(67) = 0

Its preserved in the save, so I attached it.

Last edited 5 months ago by tentaclemoose (previous) (diff)

by tentaclemoose, 5 months ago

Attachment: bladerunner-win.008 added

comment:4 by antoniou79, 5 months ago

So it seems that for some reason, the "gun"'s goal is set to 0 (it should not do that in that scene) and the "actor" is teleported at another placeholder set (which is expected when their goal is changed to 0).
There are only a couple of cases that this might happen, and one is more likely to be buggy (CompletedMovementTrack) than the other (OtherAgentExitedThisScene).

comment:5 by peterkohaut, 5 months ago

i wonder if its the same issue as fish dealer in chapter 5, movement track is not reset before changing the goal

comment:6 by antoniou79, 5 months ago

Possible fixes:
https://github.com/scummvm/scummvm/commit/72329773d449e0abe36b4dde45aab3927f0677ea
https://github.com/scummvm/scummvm/commit/9fa862c0f40f5d04ae7c520ae6fdd6797bc79b6a

I am unable to reproduce this on my own. Although I do remember a time that it used to happen to my installation too. The attached save file helps to zero in on what might be going on (probably a missing movement flush) but I was still unable to have the bug happen to me (without loading up the save game).

I believe that the above commits should remove the issue entirely.

comment:7 by antoniou79, 5 months ago

Owner: set to antoniou79
Resolution: fixed
Status: newpending

pending feedback from the ticket creator

comment:8 by antoniou79, 4 months ago

Status: pendingclosed

The bug is considered fixed. No new feedback from the ticket creator in a week.

Note: See TracTickets for help on using tickets.