Opened 4 weeks ago

Closed 4 weeks ago

#10984 closed defect (fixed)

Chinatown Crash. (Non-HDFRAMES.DAT only)

Reported by: CallistoNTG Owned by: antoniou79
Priority: normal Component: Engine: Bladerunner
Keywords: Cc:
Game: Blade Runner with restored content

Description

Attempting to travel to Chinatown in Chapter 2 produces the following error:
"Unable to locate Page 2224 for animation 673 frame 12". This crash only occurs if running from the original CDFRAMES1-4 files instead of the HDFRAMES combined archive.

This crash first occurred when playing the game using the Cut Content option. Switching over to standard mode, but using the Cut Content save files still results in the same crash.

Attachments (2)

bladerunner-final-win.017 (28.4 KB) - added by CallistoNTG 4 weeks ago.
bladerunner-final-win.2.017 (28.4 KB) - added by CallistoNTG 4 weeks ago.
Save file. Enter the Spinner and select Chinatown to trigger crash.

Download all attachments as: .zip

Change History (9)

Changed 4 weeks ago by CallistoNTG

Attachment: bladerunner-final-win.017 added

Changed 4 weeks ago by CallistoNTG

Attachment: bladerunner-final-win.2.017 added

Save file. Enter the Spinner and select Chinatown to trigger crash.

comment:1 in reply to:  description Changed 4 weeks ago by CallistoNTG

Replying to CallistoNTG:

This crash first occurred when playing the game using the Cut Content option. Switching over to standard mode, but using the Cut Content save files still results in the same crash.

I just remembered that the game overrides the current mode based on save file. So it's possible this crash is caused by the Cut Content mode.

comment:2 Changed 4 weeks ago by peterkohaut

Animation 673 belongs to Howie Lee and he is not supposed to be in his kitchen after chapter 1 and his animation is not included in the files loaded for chapter 2 (files from chapter 1 are unloaded). But in the version with restored content we put him back in.

I confirm, this is a bug in the version with restored content.

Solution would be, that the version with restored content will require HDFRAMES.DAT

Saves from this version contain states which are not compatible with normal version and mixing of them is disabled by us to avoid crazy state mixes and weird bugs.

Last edited 4 weeks ago by peterkohaut (previous) (diff)

comment:3 Changed 4 weeks ago by peterkohaut

Game: Blade RunnerBlade Runner with restored content

comment:4 Changed 4 weeks ago by antoniou79

Requiring HDFRAMES.DAT is one solution, but I worked on another solution yesterday since I didn't want to enforce a different installation type to the user for this version of the game.
The solution basically opens all four CDFRAMESx.DAT files in restored content mode so it essentially can look up all animations like when there is a single HDFRAMES.DAT.
I've tested quite a few times and it seems to work fine. I'll push later today.

comment:5 Changed 4 weeks ago by antoniou79

Owner: set to antoniou79

comment:7 Changed 4 weeks ago by antoniou79

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.