Opened 5 weeks ago

Closed 5 weeks ago

#10978 closed defect (fixed)

SCI: QFG4: Domovoi never appears

Reported by: sluicebox Owned by: sluicebox
Priority: normal Component: Engine: SCI
Keywords: sci32 original has-pull-request Cc:
Game: Quest for Glory 4

Description

QFG4 has a game breaking event bug where if you don't talk to the Domovoi before Bella wakes you up then he will never appear again and the doll can then never be retrieved. This is a regression introduced in the CD version.

http://www.sierrahelp.com/Games/QuestForGlory/QfG4Help.html#TanyasDoll
https://www.gog.com/forum/quest_for_glory_series/read_this_to_avoid_frustration_if_first_time_qfg4_player
https://www.gog.com/forum/quest_for_glory_series/qfg4_inventory_hack_to_fix_domovoi_bug

Attached is a save at night in the bedroom on day 7 after being woken up by Bella and listening to her conversation but before talking to the Domovoi. This can't be completed because the Domovoi will never appear in the main room. With the patch, the Domovoi will continue to appear so that he can be talked to.

Attachments (1)

qfg4-cd.040 (35.1 KB) - added by sluicebox 5 weeks ago.

Download all attachments as: .zip

Change History (3)

Changed 5 weeks ago by sluicebox

Attachment: qfg4-cd.040 added

comment:1 Changed 5 weeks ago by sluicebox

Owner: set to sluicebox

comment:2 Changed 5 weeks ago by bluegr

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.