Opened 5 weeks ago

Closed 5 weeks ago

#10977 closed defect (fixed)

SCI: SQ4 Sequel police mall lockup and more

Reported by: sluicebox Owned by: sluicebox
Priority: normal Component: Engine: SCI
Keywords: original has-pull-request Cc:
Game: Space Quest 4

Description

I'm bundling these bugs together because they're all part of the same sequence.

  1. Hiding from the police in the electronics store locks up the game (CD)
  2. With that fixed, the police shoot into the mall instead of standing on the beltways (CD)
  3. After this, when escaping skate-o-rama at Sock's the police appear as if they're swimming in zero gravity and kill you (All versions)

To reproduce the first two with attached save, walk into the store. After the first message the game will lockup. Use the debugger command "send sp1Squeeze ticks 1" to force the script to continue and see the unintended shooting animation.

To reproduce the third with attached save, exit skate-o-rama to the left.

Attachments (5)

lockup.png (114.8 KB) - added by sluicebox 5 weeks ago.
shooting_spree.png (115.9 KB) - added by sluicebox 5 weeks ago.
swimmin_on_belt.png (124.8 KB) - added by sluicebox 5 weeks ago.
sq4-cd.083 (36.8 KB) - added by sluicebox 5 weeks ago.
sq4-cd.084 (36.3 KB) - added by sluicebox 5 weeks ago.

Download all attachments as: .zip

Change History (8)

Changed 5 weeks ago by sluicebox

Attachment: lockup.png added

Changed 5 weeks ago by sluicebox

Attachment: shooting_spree.png added

Changed 5 weeks ago by sluicebox

Attachment: swimmin_on_belt.png added

Changed 5 weeks ago by sluicebox

Attachment: sq4-cd.083 added

Changed 5 weeks ago by sluicebox

Attachment: sq4-cd.084 added

comment:2 Changed 5 weeks ago by Filippos Karapetis <bluegr@…>

In bdf85e33:

SCI: Fix SQ4 Sequel police electronics store bugs

Fixes lockup, animation, and flag bugs when hiding in the
electronics store, bug #10977

comment:3 Changed 5 weeks ago by bluegr

Owner: set to sluicebox
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.