Opened 5 weeks ago

Closed 5 weeks ago

#10975 closed defect (fixed)

SCI: FPFP: Reappearing items

Reported by: sluicebox Owned by: sluicebox
Priority: normal Component: Engine: SCI
Keywords: original has-pull-request Cc:
Game: Freddy Pharkas: Frontier Pharmacist

Description

These are two different bugs but they're similar and I'm fixing them at the same time.

The church key and the desk letter both incorrectly reappear after they've been removed from the game. You can get them again after and get duplicate points. Sierra attempted to fix both of these bugs but blew it. The key is fixed in Mac but not CD, and the desk letter was half-fixed in a way that has no effect.

To reproduce with the attached English PC floppy saves in Act 4...

  • Look in the desk drawer to find the letter. It was already buried in a grave in an earlier act.
  • Open the church door and look at it to see the key. It was automatically removed from the game at the start of act 4.

Attachments (2)

freddypharkas.065 (48.1 KB) - added by sluicebox 5 weeks ago.
freddypharkas.066 (37.8 KB) - added by sluicebox 5 weeks ago.

Download all attachments as: .zip

Change History (5)

Changed 5 weeks ago by sluicebox

Attachment: freddypharkas.065 added

Changed 5 weeks ago by sluicebox

Attachment: freddypharkas.066 added

comment:1 Changed 5 weeks ago by sluicebox

Owner: set to sluicebox

comment:2 Changed 5 weeks ago by Filippos Karapetis <bluegr@…>

In 23c6c13d:

SCI: Fix FPFP reappearing items, bug #10975

Fixes two similar bugs where inventory items reappear after being
used due to incorrect or missing flag checks

comment:3 Changed 5 weeks ago by bluegr

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.