Opened 3 weeks ago

Last modified 11 days ago

#10967 pending defect (worksforme)

[Lands of Lore DOS Floppy English] Crash on assertion on the herb shop

Reported by: vanfanel Owned by: athrxx
Priority: normal Component: Engine: Kyra
Keywords: crash, assertion, CD, floppy, lol Cc:
Game: Lands of Lore

Description

Hi there,

This bug only happens on the FLOPPY version of the game, not on the CD version.

Steps to reproduce:
As you start the game, enter the herb shop on the castle and talk to the herb master. The game will crash on assertion error when you click on the herb master picture to get clues.

It happens on X86_64 and aarch64 builds, GNU/Linux.
Latest GIT MASTER build as of 05/28/2019.

Change History (2)

comment:1 Changed 3 weeks ago by vanfanel

Crash info:

User picked target 'lol' (gameid 'lol')...
  Looking for a plugin supporting this gameid... Kyra
  Starting 'Lands of Lore: The Throne of Chaos'
scummvm: common/str.cpp:116: Common::String::String(const Common::String&): Assertion `_str != nullptr' failed.

comment:2 Changed 11 days ago by athrxx

Owner: set to athrxx
Resolution: worksforme
Status: newpending

Thank you for your report. I am sorry to say than I cannot reproduce that issue. Which basically means I cannot be of much help at the moment.

I tried the installed English floppy version (Extracted/DOS/English) and the non-installed German floppy version (DOS/German). When I start a new game, enter Nathaniel's shop and click on him he says "They say the ruby and the shard are the only means of opposing the nether mask!" (in the German version he says something in German obviously). There is no assert or any other type of error.

Maybe your game data files are incomplete or corrupt?

Note: See TracTickets for help on using tickets.