Opened 12 days ago

Closed 11 days ago

#10959 closed defect (fixed)

DRASCULA: Can't load save from launcher

Reported by: dafioram Owned by: criezy
Priority: normal Component: Engine: Drascula
Keywords: Cc:
Game: Drascula

Description

Using the current Drascula.dat it crashes if I load a save from the launcher, but it works fine in game.

This is with scummvm 2.0 or recent master (7f9eaf0f12632bd).

#0  0x0000555555d6eb60 in Drascula::DrasculaEngine::decodeRLE(unsigned char*, unsigned char*, unsigned short) (this=0x5555585e8690, srcPtr=0x55555915f3b2 "\377", dstPtr=0x1 <error: Cannot access memory at address 0x1>, pitch=0)
    at engines/drascula/graphics.cpp:668
#1  0x0000555555d6c981 in Drascula::DrasculaEngine::loadPic(char const*, unsigned char*, int) (this=0x5555585e8690, NamePcc=0x5555585e96bc "AUX62.ALG", targetSurface=0x0, colorCount=1) at engines/drascula/graphics.cpp:108
#2  0x0000555555d7b190 in Drascula::DrasculaEngine::enterRoom(int) (this=0x5555585e8690, roomIndex=62) at engines/drascula/rooms.cpp:1781
#3  0x0000555555d7ecdc in Drascula::DrasculaEngine::loadGame(int) (this=0x5555585e8690, slot=3) at engines/drascula/saveload.cpp:332
#4  0x0000555555d67cb2 in Drascula::DrasculaEngine::run() (this=0x5555585e8690) at engines/drascula/drascula.cpp:277
#5  0x000055555596b470 in runGame(Plugin const*, OSystem&, Common::String const&) (plugin=0x5555584cf820, system=..., edebuglevels=...) at base/main.cpp:273
#6  0x000055555596c74f in scummvm_main(int, char const* const*) (argc=1, argv=0x7fffffffdfb8) at base/main.cpp:545
#7  0x0000555555968c2c in main(int, char**) (argc=1, argv=0x7fffffffdfb8)
    at backends/platform/sdl/posix/posix-main.cpp:45

Change History (4)

comment:1 Changed 11 days ago by criezy

Which platform is this on?
Can you attached a save game?

For me with the current master it doesn't crash when loading from the launcher, whether I load an old save game or one created with the current code. So I am wondering if the issue is specific to some platforms, or to some save games.

comment:2 Changed 11 days ago by criezy

Owner: set to criezy

Looking at your call stack for the crash and at the source code, I think the only way to get in this situation is if you are loading a game that was saved in chapter 1 (before going up to the room). And indeed I can reproduce the crash with such a save game. I know what is wrong, and now I just have to find the best way to fix this.

comment:3 Changed 11 days ago by criezy

In 92300268:

DRASCULA: Fix loading game from launcher

This was particularly an issue when the game had been saved in
chapter 1 as in this case the load would happen too early and
the game would crash. In other cases it was working but was
not optimal (the gane loop was run once before it succeeded
to load the game).

This fixes bug #10959.

comment:4 Changed 11 days ago by criezy

Resolution: fixed
Status: newclosed

This should now be fixed.

Note: See TracTickets for help on using tickets.