Opened 6 months ago

Last modified 5 months ago

#10957 new defect

[Discworld 1 CD/DOS] Psy office event not triggered

Reported by: nemo93 Owned by:
Priority: low Component: Engine: Tinsel
Keywords: Cc:
Game: Discworld

Description

Hello,

It's my first ticket hence please bear with me if something is not done the way it should.

ScummVm version: the one bundled with Retropie. Issue persists on ScummVM 2.0.0 and nightlies.

$ scummvm -v
ScummVM 2.0.1pre (Mar 23 2019 11:16:47)
Features compiled in: TAINTED Vorbis FLAC MP3 ALSA SEQ TiMidity RGB zLib MPEG2
FluidSynth Theora AAC FreeType2 JPEG PNG keymapper virtual keyboard

Bug details: to progress the game at some point you must visit the psychiatrist (aka Psychiatrickerist) for him to provide some ink blot papers. Yet whatever I do I'm never called up to his office. After reading on the Web, you know the event will be triggered whenever the left most seat (close to the secretary) is empty. For me it's never empty, the milkmaid lady is seating there all the time.

I'm following a walkthrough (here -- in French!) hence I was not expecting this to happen. I've talked to as many characters as I could and try to exit/re-enter the office multiple times. Also trying to speak to the Troll and milkmaid failed to trigger the event.

How to reproduce: I do have 2 savegames available that I attach to the ticket. Issue above is 100% reproducible using these saves as I did test on another ScummVM version (on my PC using the latest build/nightly as well as latest stable release 2.0.0 for Win10.

Language of game: English

Version of game: CD DOS/Talkie and I believe it's version 2 as I do have *.SCN files (no *.GRA).

OS/device: I'm running ScummVM on a Raspberry 3B+.

$ uname -a
Linux retropie 4.14.98-v7+ #1200 SMP Tue Feb 12 20:27:48 GMT 2019 armv7l GNU/Linux

$ lsb_release -a
No LSB modules are available.
Distributor ID: Raspbian
Description:    Raspbian GNU/Linux 9.9 (stretch)
Release:        9.9
Codename:       stretch

Thanks a lot for your assistance.

Attachments (7)

dw-cd.001 (2.4 KB ) - added by nemo93 6 months ago.
dw-cd.002 (3.8 KB ) - added by nemo93 6 months ago.
dw-cd.001.luggage.png (189.5 KB ) - added by nemo93 5 months ago.
dw-cd.001.rincewind.png (199.0 KB ) - added by nemo93 5 months ago.
dw-cd.002.luggage.png (231.8 KB ) - added by nemo93 5 months ago.
dw-cd.002.rincewind.png (267.1 KB ) - added by nemo93 5 months ago.
dw-cd.2.002 (3.3 KB ) - added by nemo93 5 months ago.

Download all attachments as: .zip

Change History (15)

by nemo93, 6 months ago

Attachment: dw-cd.001 added

by nemo93, 6 months ago

Attachment: dw-cd.002 added

comment:1 by dafioram, 5 months ago

Thanks for your submission.

I cannot load your saves. My version uses *.GRA so perhaps that is why.

I assume you are trying to visit the psychiatrist to get the inkblots in Act 2?

comment:2 by nemo93, 5 months ago

I do confirm my saves won't work on version with *.GRA (version 1?). You do need version 2 or the one with *.SCN.

You're also correct in saying I'm trying to get the inkblots in Act 2.

Last edited 5 months ago by nemo93 (previous) (diff)

comment:3 by dafioram, 5 months ago

Can you double check that you have gone to the thief's hideout and participated in the chanting? For my save before the inkblot that was an important trigger for that made the inkblot part possible.

If that doesn't work can you send me a picture of your current inventory (Rincewind + Luggage) so we can compare inventory? Thanks.

by nemo93, 5 months ago

Attachment: dw-cd.001.luggage.png added

by nemo93, 5 months ago

Attachment: dw-cd.001.rincewind.png added

by nemo93, 5 months ago

Attachment: dw-cd.002.luggage.png added

by nemo93, 5 months ago

Attachment: dw-cd.002.rincewind.png added

comment:4 by nemo93, 5 months ago

Sure thing. On save 1 (dw-cd.001) it was done early in Act 2 hence I haven't achieved the hideout part by then. I've added screenshots anyway.

However on save 2 (dw-cd.002) hideout part was complete (the pipe, the glass, the robe and chanting etc). I realize some important items are not in the inventory as I gave them already to dragon. Those items are:

  • gold tooth,
  • golden belt,
  • golden brush.

=> Please note that I've tried also to get to psy even when I had all 3 golden items mentioned above. Still without any success.

I can't get the 3 other items as this issue prevents me from doing so (cap with the golden bell, golden key and golden trowel).

Last edited 5 months ago by nemo93 (previous) (diff)

comment:5 by dafioram, 5 months ago

Getting the gold tooth required visiting the psy and getting a notice from the girl (after the inkblots should of been obtained).

Is it possible that you got that notice and didn't get the inkblots at that point? Do you have a save before you got the notice (and golden tooth) to test that?

Some items I had that you didn't were: Fertilizer, Donkey, Picture, tomato, keg, doll. Its possible that none of these matter or that you have already used them.

Last edited 5 months ago by dafioram (previous) (diff)

comment:6 by nemo93, 5 months ago

Is it possible that you got that notice and didn't get the inkblots at that point?
=> absolutely correct.

My first save is just at the beginning of Act2. Whenever I'll find time I'll test further combinations and report back.

Based on the walkthrough I've used all along when starting Act2, here is what I did in that exact order:

L space

  • to gave dragon's gold/treasure to the sleazy man in the university library.
  • got the golden banana and gave it to monkey => door to the L space.

secret brotherhood

  • then I did the part related to the secret brotherhood (to get the robe to enter the hideout etc).
  • I've collected at this stage in addition to the robe: the matches, the pot, the pint and the glass.

golden brush

  • once done I've accomplished the golden brush part. Where I had to collect the doll, keg and fireworks. Doll and keg have been both used and thus are not in my inventory any longer.

golden belt

  • after that I went on getting the golden belt. I had to deal with the inn and sheet stuff to get the city pass.
  • I had to use city pass to get out of the city where I got the feather, egg and custard (used shortly after). During that phase I also collected drumstick in order to get the prunes.

gold tooth

  • I went on with gold tooth. Got a donut from Dibbler / gave it ot Dunnyman.
  • then I talked to the Lovable Street Starfish.
  • now the critical part: still based on my (french) walkthrough I had to enter the psy office and talk to the troll. And this should have triggered the "psy event" to get the inkblots. But never happened.
  • what happens though is that when I entered a second time to the psy office and talked to the maid she gave me the notice. I was then able to get the tooth.

I never heard about the donkey so for sure it was not part of my inventory. The tomato I've used it on the square and never kept it with me. The picture you might refer to the one from the fishmonger perhaps? According to my walkthrough I won't need fertilizer until Act 3 hence I didn't have it with me for sure.

I've found another walkthrough that I'll try to follow next time instead:
https://www.ign.com/faqs/2003/discworld-walkthroughfaq-424442

Appreciate the help and I'll report back soon. If you have any "checklist" to be sure what's needed and what's not that would be awesome I guess.

Last edited 5 months ago by nemo93 (previous) (diff)

by nemo93, 5 months ago

Attachment: dw-cd.2.002 added

comment:7 by nemo93, 5 months ago

As promised I've followed the another walkthrough and this time... I could get to the front chair (and get the inkblots)! I've made a save right before entering the psy office but if you get inside you'll be seating in the front chair. You can get it from the ticket (here => attachment:dw-cd.2.002).

Meaning that the first walkthrough was perhaps for the 1st version of game or simply wrong (despite being for DOS version, the other is for PSX). Anyway something was wrong and I don't see what exactly.

Feel free to close the ticket or I can do that if you ask me to. Thanks for the assistance.

comment:8 by dafioram, 5 months ago

Priority: blockerlow

Thanks for checking that. I'm glad it worked when you took different steps.

It would still be good to have your second save (dw-cd.002( checked in code to see what state it is in since it may be the case that it is blocked.

Lowering the priority.

If I get some time I may play Act2 from your original guide and see if I get blocked as well (on the GRA version).

Note: See TracTickets for help on using tickets.