Opened 6 months ago

Closed 5 months ago

#10954 closed defect (fixed)

SCI: FPFP: Mac is missing view of cook leaving town

Reported by: sluicebox Owned by: sluicebox
Priority: normal Component: Engine: SCI
Keywords: original has-pull-request Cc:
Game: Freddy Pharkas: Frontier Pharmacist

Description

Walking to the desert (room 200) at the end of act 3 after target practice crashes the Mac version due to missing view 844. This is a bug in the original and would crash Sierra's interpreter.

View 844 is of the cook leaving town. This bug is unrelated to #10953 regarding how the view was read in PC versions. Mac doesn't have the view at all.

To reproduce with attached save, walk left to room 200.

Attachments (1)

freddypharkas-mac.004 (39.2 KB ) - added by sluicebox 6 months ago.

Download all attachments as: .zip

Change History (4)

by sluicebox, 6 months ago

Attachment: freddypharkas-mac.004 added

comment:2 by Filippos Karapetis <bluegr@…>, 5 months ago

In 29028731:

SCI: Disable FPFP Mac script that uses missing view

Fixes bug #10954

comment:3 by bluegr, 5 months ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.