Opened 3 weeks ago

Closed 3 weeks ago

#10953 closed defect (fixed)

SCI: FPFP: Crash when the cook leaves town

Reported by: sluicebox Owned by: sluicebox
Priority: normal Component: Engine: SCI
Keywords: has-pull-request Cc:
Game: Freddy Pharkas: Frontier Pharmacist

Description

Walk to the desert (room 200, far left) after target practice and ScummVM fails an assertion. This affects all versions of the game. This scene worked in the original, at least in DOS versions.

This crash is due to an unusual view that isn't being read the way Sierra's interpreter did.

The Mac version doesn't work either, but for a different reason on top of this, which I'm looking into. The view is either missing from that version or ScummVM isn't finding it.

To reproduce with attached save from DOS floppy version, walk left.

To reproduce in any version with the debugger:

  1. vv g 119 19
  2. room 200

Attachments (1)

freddypharkas.041 (46.0 KB) - added by sluicebox 3 weeks ago.

Download all attachments as: .zip

Change History (4)

Changed 3 weeks ago by sluicebox

Attachment: freddypharkas.041 added

comment:1 Changed 3 weeks ago by sluicebox

Owner: set to sluicebox

comment:2 Changed 3 weeks ago by Filippos Karapetis <bluegr@…>

In 6790855:

SCI: Handle recursive view loop references

Fixes bug #10953 in FPFP

comment:3 Changed 3 weeks ago by bluegr

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.