Opened 4 weeks ago

Closed 3 weeks ago

#10952 closed defect (fixed)

SCI: FPFP: Act 2 error when walking up stairs after restaurant

Reported by: sluicebox Owned by: sluicebox
Priority: normal Component: Engine: SCI
Keywords: has-pull-request Cc:
Game: Freddy Pharkas: Frontier Pharmacist

Description

ScummVM throws an error when walking up the hotel stairs after entering the restaurant in act 2:

tried to cmdSendMidi on non midi slot (0001:211a)!

To reproduce with attached save of PC Floppy at the start of Act 2:

  1. Walk left and enter the restaurant
  2. Leave the restaurant, walk around back, and go upstairs


This is due to the game script attempting to mute/unmute a Sound object with kDoSound SendMidi while the sound object is not a midi sound. The object, gameMusic2, is set to the sample of people talking in the restaurant. All versions of FPFP do this and there is there is another script which also mutes/unmutes this way.

Attachments (1)

freddypharkas.007 (48.7 KB) - added by sluicebox 4 weeks ago.

Download all attachments as: .zip

Change History (4)

Changed 4 weeks ago by sluicebox

Attachment: freddypharkas.007 added

comment:1 Changed 4 weeks ago by sluicebox

Owner: set to sluicebox

comment:2 Changed 3 weeks ago by Filippos Karapetis <bluegr@…>

In 7862140:

SCI: Change sendMidiCommand non-midi error to warn

FPFP calls kDoSound SendMidi on non-midi sounds. Fixes bug #10952

comment:3 Changed 3 weeks ago by bluegr

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.