Opened 7 months ago

Closed 3 weeks ago

Last modified 3 weeks ago

#10933 closed defect (fixed)

SCUMM: [Pajama Sam 2, English GB] Crash/Exit upon launching game, "failed to read MAXS data"

Reported by: Retrodude94 Owned by: BenCastricum
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Pajama Sam 2

Description

  • ScummVM version 2.0.0 Windows x86
  • Windows 7 Professional 64-bit OS
  • Pajama Sam: Thunder and Lightning Aren't So Frightening (UK/GB English CD-ROM)

Game datafiles are recognized but fails to launch. Upon pressing Start in ScummVM UI main windows goes black for a split second before closing both main and console windows.
Output from scummvm.log shows the following:
--
readMAXS(52) failed to read MAXS data!
[2019-04-11 19:28:43] --- Log closed successfully.
--

Let me know if any additional information is needed.

Change History (13)

comment:1 by Retrodude94, 7 months ago

Component: --Unset----Other--

comment:2 by digitall, 7 months ago

Component: --Other--Engine: SCUMM
Keywords: Crash removed
Summary: [Pajama Sam 2, English GB] Crash/Exit upon launching game, "failed to read MAXS data"SCUMM: [Pajama Sam 2, English GB] Crash/Exit upon launching game, "failed to read MAXS data"

comment:3 by digitall, 7 months ago

In your case, it is a blocksize of 52 which is not valid for v6 MAXS.

I think this is called as the blocksize is not equal to 40 which would indicate a HE v7.2 engine:
https://github.com/scummvm/scummvm/blob/master/engines/scumm/he/resource_he.cpp#L318

comment:4 by digitall, 7 months ago

Aha... This looks like it should be detected as a HE v9.9 game as per:
https://github.com/scummvm/scummvm/blob/master/engines/scumm/he/resource_he.cpp#L254

comment:5 by digitall, 7 months ago

I think the root cause is this line here which indentifies pajama2 as a HE v6 95 rather than 99 game:
https://github.com/scummvm/scummvm/blob/master/engines/scumm/detection_tables.h#L348

Changing that line from 95 to 99 would probably fix the issue, but not sure how many copies of the game are different versions...

comment:6 by BenCastricum, 7 weeks ago

Most likely the MD5 is missing. Can you add the complete logfile? Or use the info from Reporting unknown MD5 checksums webpage to determine the md5?

comment:7 by JeffCharizardFlame, 4 weeks ago

I can confirm that I have this issue as well with my copy of the UK disc. I've checked my own logfile and it does not give me any MD5s for some reason. However, when using the Git executable I got this text. I am getting this in Windows 10 verson 1903.

Adding to SearchMan: C:\ROMS\ScummVM\Pajama Sam 2 - Thunder and Lightning Aren't So Frightening (CD Windows, UK)\
Checking for OBJETS/VS1.HLZ
not found
User picked target 'pajama2-win-gb' (gameid 'pajama2')...
  Looking for a plugin supporting this gameid... SCUMM [all games]
  Starting 'Pajama Sam 2: Thunder and Lightning Aren't so Frightening'

Dunno if this helps any.

Last edited 4 weeks ago by JeffCharizardFlame (previous) (diff)

comment:8 by BenCastricum, 3 weeks ago

Based on al this, this is about md5 2328be0317008ef047eed7912a4b0850, the only pajama2-win-gb ScummVM currently knows. The error message, specifically the "52" in "readMAXS(52) failed" indicates this is a HE99 (or higher) game. In ScummVM the HE version is set to HE 98.5 for this device which explains the error. Changing this to HE99 should fix this. I submitted PR1902 for this.

Last edited 3 weeks ago by BenCastricum (previous) (diff)

comment:9 by Filippos Karapetis <bluegr@…>, 3 weeks ago

In e620372d:

SCUMM: Bump HE version of Pajama2 GB to 99, Fixes bug #10933

comment:10 by bluegr, 3 weeks ago

Owner: set to BenCastricum
Resolution: fixed
Status: newclosed

comment:11 by BenCastricum, 3 weeks ago

Even though this ticket is closed, I would appreciate if someone could confirm this fixes it as I personally don't have access to this specific version of the game.

comment:12 by goodoldgeorge, 3 weeks ago

The game started without any error message.

GameID: pajama2-win-gb
PajamaTAL.HE0: 2328be0317008ef047eed7912a4b0850

ScummVM version: ScummVM 2.2.0git556-g7533375b55-dirty (Oct 25 2019 05:06:02)

in reply to:  12 comment:13 by Retrodude94, 3 weeks ago

Replying to goodoldgeorge:

The game started without any error message.

GameID: pajama2-win-gb
PajamaTAL.HE0: 2328be0317008ef047eed7912a4b0850

ScummVM version: ScummVM 2.2.0git556-g7533375b55-dirty (Oct 25 2019 05:06:02)

Seconded, same GameID and checksum on my system, game is working as intended on latest daily build (2.2.0git556-g7533375b55)

Note: See TracTickets for help on using tickets.