Opened 8 months ago

Closed 8 months ago

#10930 closed defect (fixed)

[GLK-Scott] Conflicting game ID in the scott sub-engine

Reported by: goodoldgeorge Owned by: dreammaster
Priority: normal Component: Engine: GLK
Keywords: Cc:
Game:

Description

ScummVM version in the logfile, OS: Windows 10 build 1809 64-bit

I added the Mysterious Adventures Scott games to ScummVM. There was a problem with part 11.

The ScummVM wants to run the AGOS waxworks game, and stops with the following error message:
in the DAT version:
[2019-04-03 07:39:36] ScummVM 2.1.0git5071-gfecfe9ec86-dirty (Apr 3 2019 05:46:19)
[2019-04-03 07:39:36] TAINTED Vorbis FLAC MP3 RGB zLib MPEG2 FluidSynth Theora AAC FreeType2 JPEG PNG cloud (servers, local)
[2019-04-03 07:39:36] --- Log opened.
[2019-04-03 07:39:49] WARNING: AGOS failed to instantiate engine: Game data not found (target 'waxworks', path 'H:\Games\')!
[2019-04-03 07:39:55] --- Log closed successfully.

in the BLB version:
[2019-04-03 07:40:36] ScummVM 2.1.0git5071-gfecfe9ec86-dirty (Apr 3 2019 05:46:19)
[2019-04-03 07:40:36] TAINTED Vorbis FLAC MP3 RGB zLib MPEG2 FluidSynth Theora AAC FreeType2 JPEG PNG cloud (servers, local)
[2019-04-03 07:40:36] --- Log opened.
[2019-04-03 07:40:47] WARNING: AGOS failed to instantiate engine: Game data not found (target 'waxworks-1', path 'H:\Games\')!
[2019-04-03 07:40:52] --- Log closed successfully.

The Game entries in the scummvm.ini file:
[waxworks]
description=Mysterious Adventures 11: Waxworks (English)
path=H:\Games\
gameid=waxworks
language=en
filename=B_waxworks.dat

[waxworks-1]
gameid=waxworks
description=Mysterious Adventures 11: Waxworks (English)
language=en
path=H:\Games\
filename=waxworks.blb

The cause of the error is a conflicting game IDs
Scott, waxworks: Mysterious Adventures 11: Waxworks
AGOS, waxworks: Waxworks

Please change this Game ID, Thank you so much.

Change History (1)

comment:1 by dreammaster, 8 months ago

Owner: set to dreammaster
Resolution: fixed
Status: newclosed

Thanks for reporting the clash

Note: See TracTickets for help on using tickets.