Opened 8 months ago

Closed 8 months ago

#10924 closed defect (fixed)

SCI: CD speech permanently muted after restoring in text mode

Reported by: sluicebox Owned by: sluicebox
Priority: normal Component: Engine: SCI
Keywords: has-pull-request Cc:
Game:

Description

This is a regression introduced between 1.9 and 2.0.

Affects CD versions of at least: SQ4, KQ6, ECO1, LB2, QFG4

To reproduce:

  1. Start or restore a game
  2. Set message mode to Text in game's control panel
  3. Restore a game
  4. Set message mode to Speech
  5. Speech is now broken because the ScummVM mixer still has speech muted

Best not test this with QFG4 since it will crash, obscuring the problem. (The fix fixes that too)

Change History (4)

comment:2 by sluicebox, 8 months ago

Also, QFG4's control panel won't always show the right results, even with this fix. That's an unrelated bug I'll be fixing soon.

comment:3 by Filippos Karapetis <bluegr@…>, 8 months ago

In 9c8d425f:

SCI: Fix broken speech after starting in text mode

Fixes bug #10924 where starting or restoring in text mode and then
changing to speech mode within a game results in muted speech.

This is a regression introduced between 1.9 and 2.0, probably as part
of the synchronization refactor that created GuestAdditions.

comment:4 by bluegr, 8 months ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.