#10920 closed defect (fixed)

SCI: SQ4 Cedric easter egg bugs (CD version)

Reported by: sluicebox Owned by: sluicebox
Priority: normal Component: Engine: SCI
Keywords: original has-pull-request Cc:
Game: Space Quest 4

Description

There are two bugs in the Cedric (KQ5 owl) easter egg in SQ4CD Ms. Astro Chicken. The first prevents it from almost ever happening, the second locks up the game when it does. It's easier to combine these here as I'm fixing them together.

The first bug is that when the the farmer appears and takes a shot, the script incorrectly concludes that the bullet has hit Cedric, and so he explodes in a puff of blood and feathers far off screen at the start of every game. Once he's dead he doesn't re-appear and so it's almost impossible to ever see him. The only clip on youtube of Cedric https://www.youtube.com/watch?v=0OZSGAO01sM shows a player who got lucky and Cedric was randomly placed at the very start before the farmer was able to take his first shot. This avoids the bug and so Cedric continues to randomly appear throughout the rest of the game as intended.

The second bug is that if Cedric collides with the player after the player has collided with an obstacle then the game locks up. The two collision animations run at the same time and interfere with each other.

Submitting script patches that fix the broken collision detection, making him randomly appear as intended, and prevents Cedric from colliding with the player if the player has already collided with an obstacle and is dying.

Attached is a save at the arcade in SQ4CD.

To reproduce... I don't know, play the game for a while, Cedric might now show up? It's hard to deliberately reproduce the second bug unless you patch out the randomness for testing like I did so that Cedric shows up all the time. Attached is a screenshot of the fix, Cedric safely flies through the player colliding with aweasel.

Attachments (2)

sq4-cd.024 (39.5 KB ) - added by sluicebox 19 months ago.
fixed-collision.png (14.6 KB ) - added by sluicebox 19 months ago.

Download all attachments as: .zip

Change History (5)

by sluicebox, 19 months ago

Attachment: sq4-cd.024 added

by sluicebox, 19 months ago

Attachment: fixed-collision.png added

comment:2 by Filippos Karapetis <bluegr@…>, 19 months ago

In 43ab746a:

SCI: Fix SQ4CD Cedric easter egg, bug #10920

comment:3 by bluegr, 19 months ago

Owner: set to sluicebox
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.