Opened 7 months ago

Closed 7 months ago

#10914 closed defect (fixed)

SCI: SQ4: Sock's door not redrawn, no message (CD version)

Reported by: sluicebox Owned by: sluicebox
Priority: normal Component: Engine: SCI
Keywords: original has-pull-request Cc:
Game: Space Quest 4

Description

The door to Sock's clothing store in the mall has bugs in the CD version. It isn't redrawn when restoring a game and it doesn't respond with its Look message. This is due to a script bug which immediately disposes of the door after adding it to the screen.

To reproduce with attached save from CD version:

  1. Wait a second for the conveyor belt to take you to Sock's
  2. Look at the door, the door message isn't shown
  3. Save game
  4. Load game, the door is gone

Attachments (1)

sq4-cd.056 (36.6 KB ) - added by sluicebox 7 months ago.

Download all attachments as: .zip

Change History (4)

by sluicebox, 7 months ago

Attachment: sq4-cd.056 added

comment:2 by Filippos Karapetis <bluegr@…>, 7 months ago

In 94bf3265:

SCI: Fix SQ4CD Sock's door, bug #10914 (#1533)

comment:3 by bluegr, 7 months ago

Owner: set to sluicebox
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.