Opened 8 months ago

Closed 7 months ago

#10912 closed defect (fixed)

SCI: SQ4: Zero gravity chase lockup

Reported by: sluicebox Owned by: sluicebox
Priority: normal Component: Engine: SCI
Keywords: original has-pull-request Cc:
Game: Space Quest 4

Description

When swimming in zero gravity in the mall, the game can lock up if the Sequel Police shoot while ego swims past the edge of the screen. This bug is in all versions.

This is a tricky bug to reproduce since it depends on timing and the random placement of the police's laser blast, but the end result is that ego gets stuck colliding with it and so the script that moves ego on and off the screen locks up.

Attached is a save game from the CD version that is locked up and can be used to test the solution. Enter into the debugger:

send blast.1 signal 0:4002


This will unlock the game and is what the script patch accomplishes.

Attachments (1)

sq4-cd.029 (31.9 KB ) - added by sluicebox 8 months ago.

Download all attachments as: .zip

Change History (4)

by sluicebox, 8 months ago

Attachment: sq4-cd.029 added

comment:2 by Filippos Karapetis <bluegr@…>, 7 months ago

In 36b4926:

SCI: Fix SQ4 zero gravity blast lockup, bug #10912

comment:3 by bluegr, 7 months ago

Owner: set to sluicebox
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.