Opened 3 weeks ago

Closed 3 weeks ago

#10908 closed defect (fixed)

[GLK-Frotz] Conflicting game IDs in the frotz engine

Reported by: goodoldgeorge Owned by: dreammaster
Priority: normal Component: Engine: GLK
Keywords: Cc:
Game: GLK Z-Code (Frotz) Game

Description

ScummVM version: ScummVM 2.1.0git4851-g4c708dc97f-dirty (Mar 3 2019 06:56:43)
Features compiled in: TAINTED Vorbis FLAC MP3 RGB zLib MPEG2 FluidSynth Theora AAC FreeType2 JPEG PNG cloud (servers, local)

OS: Windows 10 build 1809 64-bit

I added the French, Champion de basket-ball frotz game to ScummVM.
The ScummVM wants to run the scumm game, Backyard Basketball, and stops with the following error message:
WARNING: SCUMM [all games] failed to instantiate engine: Game data not found (target 'basketball', path 'H:\Games\')!

The cause of the error is a conflicting game IDs
Frotz: basketball - Champion de basket-ball
Scumm: basketball - Backyard Basketball

Please, Someone change this Game ID, Thank you

This is the entry of the game in the scummvm.ini file:
[basketball]
description=Champion de basket-ball (180904/French)
extra=180904
path=H:\Games\
gameid=basketball
language=fr
filename=basket_ball.z5
guioptions=sndNoSubs sndNoMusic sndNoSpeech sndNoSFX

I found one more possible Conflicting game IDs:
Frotz : arthur - Arthur: The Quest for Excalibur
Mohawk: arthur - Arthur's Teacher Trouble

I haven't tested this, but it may be a problem when running the game.

Change History (1)

comment:1 Changed 3 weeks ago by dreammaster

Game: GLK Z-Code (Frotz) Game
Owner: set to dreammaster
Resolution: fixed
Status: newclosed

Thanks for discovering that, they're now fixed. Word of warning though.. Arthur Quest for Excalibur is a version 6 Infocom game, and support for them is still in progress.

Note: See TracTickets for help on using tickets.