Opened 4 weeks ago

Closed 4 weeks ago

#10896 closed defect (fixed)

SCI: LONGBOW: Day 8 archer pathfinding lockup

Reported by: sluicebox Owned by: bluegr
Priority: normal Component: Engine: SCI
Keywords: has-pull-request Cc:
Game: Conquests of the Longbow

Description

When the guards kick Robin out of archery room 320 the game locks up due to ScummVM's pathfinding. It sends Robin in the wrong direction, colliding with a guard, preventing the script from continuing and locking up the game.

To reproduce with attached save (DOS v1.1), walk left to enter tournament room.

Attachments (1)

longbow.002 (53.3 KB) - added by sluicebox 4 weeks ago.

Download all attachments as: .zip

Change History (4)

Changed 4 weeks ago by sluicebox

Attachment: longbow.002 added

comment:2 Changed 4 weeks ago by Filippos Karapetis <bluegr@…>

In d1b1bd53:

SCI: Fix LONGBOW Day 8 archer pathfinding

Work around a lockup that occurs due to our pathfinding, bug #10896

comment:3 Changed 4 weeks ago by bluegr

Owner: set to bluegr
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.