Opened 5 weeks ago

Closed 4 weeks ago

#10895 closed defect (fixed)

SCI: LB2: Armor rooms don't display messages

Reported by: sluicebox Owned by: bluegr
Priority: normal Component: Engine: SCI
Keywords: original has-pull-request Cc:
Game: Laura Bow 2: The Dagger of Amon-Ra

Description

The armor exhibit rooms (440 and 448) don't display messages when clicking on the rooms, even though each room has several messages. The game doesn't even respond with a generic message, it just does nothing when they're clicked. This due to a script bug in each room's event handler and also occurs in the original.

To reproduce with any version, use the debugger to warp to room 440 and 448 and click on the walls or floor. Nothing will happen. Each room has messages for Look, Do, and Magnifying Glass.

Attachments (1)

message.png (112.4 KB) - added by sluicebox 5 weeks ago.

Download all attachments as: .zip

Change History (4)

Changed 5 weeks ago by sluicebox

Attachment: message.png added

comment:2 Changed 4 weeks ago by Filippos Karapetis <bluegr@…>

In 3158285e:

SCI: Fix LB2 armor exhibit messages, bug #10895

Fixes script bugs in the original that prevent messages.
Replaces a script patch that fixed one of the symptoms.

comment:3 Changed 4 weeks ago by bluegr

Owner: set to bluegr
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.