Opened 16 years ago

Closed 16 years ago

Last modified 16 years ago

#1089 closed defect (fixed)

RC 0.5.0: MI2: Reoccuring crash

Reported by: SF/superqult Owned by: SF/jamieson630
Priority: blocker Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 2

Description

Whenever I walk into the Booty Boutique on Booty
Island, the game crashes.

ScummVM version: pre-0.5.0 version for MacOS X (July 24th)
Bug Details: Use the enclosed save game, and just walk
into the store.
Language of game: English
Version of game: Mac (there's only one mac version, right?)
Platform and compiler: MacOS X 10.2.6, and gcc 3.1 (I
didn't compile ScummVM myself though, it's the one from
the downloads-page)

Ticket imported from: #780675. Ticket imported from: bugs/1089.

Attachments (1)

monkey2.s01.sit (14.5 KB ) - added by SF/superqult 16 years ago.
Saved state, outside the Booty Boutique

Download all attachments as: .zip

Change History (7)

by SF/superqult, 16 years ago

Attachment: monkey2.s01.sit added

Saved state, outside the Booty Boutique

comment:1 by SF/superqult, 16 years ago

Priority: normalblocker
Summary: Reoccuring crashMI2: Reoccuring crash

comment:2 by SF/jamieson630, 16 years ago

Owner: set to SF/jamieson630
Summary: MI2: Reoccuring crashRC 0.5.0: MI2: Reoccuring crash

comment:3 by SF/jamieson630, 16 years ago

Got my hands on the Mac files for analysis. A fix is in CVS. I
didn't actually see the Booty Botique crash because I
encountered what I suspect was the same crash back on
Scabb Island, when trying to dig up the grave. By the time I
got to Booty Island, I had implemented the fix, and all the
shops on Booty Island seem to be behaving properly now.

The regression is caused by less stringent handling of out-of-
bounds track selection in the MidiParser that iMuse went to
after 0.4.1. Apparently some Mac tracks use jump commands
that include a track of -1, presumably to indicate "jump within
the same track." I've tightened up the OOB handling in
MidiParser.

Fingolfin, if this fix takes care of the problem you were able to
reproduce, go ahead and close this out. Also, would you mind
backporting the fix to 0.5.0?

comment:4 by SF/jamieson630, 16 years ago

I removed the OOB fix to test the botique, and it does crash
once I remove the fix. So, I think this was the one.

comment:5 by fingolfin, 16 years ago

You da' man, Jamieson :-) Very much appreciated. I can confirm
that this fixes the problem, and backported your change to the
0.5.0 branch.

comment:6 by fingolfin, 16 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.