Opened 7 weeks ago

Closed 5 weeks ago

#10864 closed defect (fixed)

Development builds no longer work on Windows XP

Reported by: DosFreak Owned by: bgK
Priority: normal Component: Port: Win32
Keywords: Cc:
Game:

Description

The development builds no longer work on Windows XP. On execution you will receive the following error:


scummvm.exe - Entry Point Not Found


The procedure entry point InitializeConditionVariable could not be located in the dynamic link library KERNEL32.dll.


OK


Unfortunately archive.org doesn't appear to have archived the site for a long time and the builds only go back a month

I do know that a build I compiled with Mingw-W64 to test the commit to fix broken <2000 support works fine so possibly not an issue witht the scummvm code but with how it's compiled?

https://buildbot.scummvm.org/builds.html

Windows (32bit) "Download latest development build"
https://buildbot.scummvm.org/snapshots/master/mingw-w32-master-latest.zip

Change History (5)

comment:1 Changed 6 weeks ago by bgK

Owner: set to bgK

Looks like my previous attempt to fix this failed. I have now recompiled fluidsynth on buildbot for the mingw32 toolchain in a way that should not require features not available on Windows XP. Please check the next nightly works properly for you.

comment:2 Changed 6 weeks ago by digitall

If this works, should also check Windows 98 as per bug #10613

comment:3 Changed 6 weeks ago by DosFreak

Just tried the 1-6-2019 @ 10:20PM dev build on Windows XP updated with the POS Nov 2018 patches.

Receive this error now:
""The procedure entry point AcquireSRWLockExclusive could not be located in the dynamic link library KERNEL32.dll"

Noticed already mentioned in this ticket:
https://bugs.scummvm.org/ticket/10809

I guess if Fluidsynth (assuming that's the issue) requires Vista+ then next official build maybe post 9x-2K SDL1 and XP SDL2 final builds.

EDIT looks like pthread may cause this issue as well but haven't veried.

Last edited 6 weeks ago by DosFreak (previous) (diff)

comment:4 Changed 5 weeks ago by DosFreak

I can confirm that the development build now works on Windows XP and Windows 2000 (with BlackWingCat Extended Kernel 2.9b w/ QindieGL (for vmware)

mingw-w32-master-2eb6bba7 1-14-2019

comment:5 Changed 5 weeks ago by bgK

Resolution: fixed
Status: newclosed

Thanks for the report. Looks like the latest fluidsynth tweaks fixed the issue.

Note: See TracTickets for help on using tickets.