Opened 16 years ago

Closed 16 years ago

Last modified 11 months ago

#1086 closed defect (fixed)

ALL: Fullscreen and -F

Reported by: SF/jellby Owned by: SF/jamieson630
Priority: normal Component: GUI
Keywords: Cc:
Game:

Description

I'm not sure if this is "GUI" or "Graphics"...

I have, in my ~/.scummvrc file (RedHat 7.3)https://sourceforge.
net/tracker/?func=add&group_id=37116&atid=516929, all games set
to "fullscreen=true", only the may [scummvm] section is set to
"fullscreen=false". I wanted a way to start a given game in
windowed mode (not fullscreen) using a command-line option and I
was told the "-F" option was the one I needed (though it's not
documented, as far as I know). These are some of the results. I first
set [scummvm] to "fullscreen=true" to test this.

$ scummvm -v
ScummVM 0.5.0pre-cvs (Jul 27 2003 13:47:16)

$ scummvm -F
[ok, the GUI starts in windowed mode]

$ scummvm -F monkey
[monkey island starts fullscreen]

$ scummvm -F tentacle
[dott starts fullscreen]

$ scummvm -F simon
Looking for simon1talkie
Trying to start game 'Simon the Sorcerer 1 Talkie (DOS)'
ALSA client initialised [65:0]
scummvm: backends/sdl/sdl.cpp:346: virtual uint32 OSystem_SDL::
property(int, OSystem::Property*): Assertion `_hwscreen != 0' failed.
Aborted

$ scummvm -F sky
Looking for sky
Trying to start game 'Beneath a Steel Sky'
ALSA client initialised [65:0]
scummvm: backends/sdl/sdl.cpp:346: virtual uint32 OSystem_SDL::
property(int, OSystem::Property*): Assertion `_hwscreen != 0' failed.
Aborted

Something is not working right here...

Ticket imported from: #779013. Ticket imported from: bugs/1086.

Change History (16)

comment:1 by eriktorbjorn, 16 years ago

I can reproduce this under Windows with the SDL backend,
too. It appears that SimonEngine::SimonEngine() toggles
fullscreen in the backend before the backend has had the
time to create _hwscreen.

Actually, it seems to be enough to just put
"fullscreen=true" in the config file.

Is it just my imagination, or is the config stuff at the end
of SimonEngine::SimonEngine() completely unnecessary? As far
as I can tell, it works just fine without it. (Except maybe
when starting from the launcher, but as far as I can see
this code doesn't help there either.)

comment:2 by eriktorbjorn, 16 years ago

Assigning to kirben since he's the one who added that code
to the Simon engine; he should know which case it's needed for.

comment:3 by eriktorbjorn, 16 years ago

Owner: set to Kirben

comment:4 by SF/jellby, 16 years ago

Two comments:

1. I was looking for an option to override "fullscreen=true" and start a
game *not* in fullscreen mode. If "-F" is such an option, it failed with all the
games I tried (but it worked with the game selector).

2. Beneath a Steel Sky gives the same error as Simon

comment:5 by SF/logicdeluxe, 16 years ago

For me it works fine, if the "fulscreen=true" line is only
present in the [scummvm] section and it is absend for the
particular game entry.
I have not tried this for the game entries before, since it
makes no sense for me to have a only particular game in
window mode and another in full screen. The only reason
using window mode is watching the debug output or the
original interpreter aside of ScummVM. This usually does not
go for a particular game.

Maybe the game specific entry has just to be ignored when
'-f' or '-F' is given. It should be overwritten anyway.

comment:6 by eriktorbjorn, 16 years ago

I've committed a fix that keeps Simon and BASS from crashing.

The bug isn't fixed though, since the config file still
overrides the command-line option. But it's a start.

comment:7 by Kirben, 16 years ago

Owner: Kirben removed

comment:8 by Kirben, 16 years ago

That code in Simon is to allow a game specific full screen or
scaler to work if a game is started via launcher.
This should be fixed by someone else, as the remaining issue
effects all modules (scumm/simon/sky).

comment:9 by fingolfin, 16 years ago

Summary: Fullscreen and -FALL: Fullscreen and -F

comment:10 by SF/ender, 16 years ago

This option should also be renamed to --no-f and probably
aliased to --no-fullscreen, in order to corrospond with
our current documentation and naming scheme.

comment:11 by SF/jamieson630, 16 years ago

-f and -F should be fixed in latest CVS, as well as other
command line options that are assumed to be [scummvm]
scope by default (such as -g). Also added --fullscreen and --
no-fullscreen to the options. (No, I did not add a --no-f
option. The idea of long options is to be able to spell things
out!)

Will wait for verification (eriktorbjorn?) before closing.

comment:12 by SF/jamieson630, 16 years ago

Owner: set to SF/jamieson630
Resolution: fixed

comment:13 by SF/khalek, 16 years ago

works here with scumm/simon/sky
surely this can be closed now?

comment:14 by SF/ender, 16 years ago

Status: newclosed

comment:15 by SF/ender, 16 years ago

Yes it can, it can.

comment:16 by digitall, 11 months ago

Component: --Unset--GUI
Note: See TracTickets for help on using tickets.