Opened 5 months ago

Closed 5 months ago

Last modified 5 months ago

#10840 closed defect (worksforme)

GLK: FROTZ: ZORK1: Could not load data file

Reported by: emmalynrenato Owned by: dreammaster
Priority: normal Component: Engine: GLK
Keywords: Cc:
Game: GLK Z-Code (Frotz) Game

Description

ScummVM 2.1.0git4321-g074177cc15 (Dec 17 2018 10:37:25)
Features compiled in: TAINTED Vorbis ALSA SEQ TiMidity RGB zLib FreeType2 PNG

Platform: Ubuntu 18.04.1 (64-bit).

I was interested in the new (unstable) glk engine, so I tried it with Zork from the GOG Zork Anthology.

I pointed it at the ZORK1.DAT file which is of type:

ZORK1.DAT: Infocom (Z-machine 3, Release 88, Serial 840726)

and the Add Game screen showed:

ID: zork1
Name: Zork I: The Great Undergropund Empire (R88-840726/English)
Language: English
Platform: <default>

and when I started it I got:

...
User picked target 'zork1' (gameid 'zork1')...

Looking for a plugin supporting this gameid... ScummGlk
Starting 'Zork I: The Great Underground Empire'

Could not load data file!

I realize that it's still very early days for the glk engine, so this
report might be premature. Please let me know if there is anything you'd
like me to try (or further information that I need to report).

Change History (5)

comment:1 Changed 5 months ago by dreammaster

Game: GLK Z-Code (Frotz) Game
Owner: set to dreammaster
Resolution: worksforme
Status: newclosed

Congrats on the first bug posting for the new engine. It sounds like either the daily build you're using, or that you built yourself, isn't automatically embedding the fonts.dat file as a resource (it's basically a zip file with a bunch of fonts). The simplest thing to do is to go to https://github.com/scummvm/scummvm/tree/master/dists/engine-data and download the fonts.dat file into the same folder as the games you're trying to add.

Alternatively, you could download it to a common folder, and use the ScummVM launcher's edit options dialog / Paths tab to point to the folder that contains it.

comment:2 Changed 5 months ago by emmalynrenato

I tried the former (copying font.dat to the same directory as the ZORK1.DAT file),
but I still get the same failure.

I also tried downloading the latest Debian 64-bit build from:
https://buildbot.scummvm.org/snapshots/master/debian-x86_64-master-latest.tar.xz
but I keep getting "Failed - Network error".

comment:3 Changed 5 months ago by emmalynrenato

I have it working now too.

When I downloaded fonts.dat from:

https://github.com/scummvm/scummvm/blob/master/dists/engine-data/fonts.dat

I used "Save link as" in my chrome browser to get the file.

The file command reports that downloaded file as:

fonts.dat: HTML document, UTF-8 Unicode text, with very long lines

and "ls -l" shows:

-rw-rw-r-- 1 emmalyn emmalyn 128871 Dec 18 10:22 fonts.dat

If I copy over the fonts.dat from my git clone:
.../dists/engine-data/fonts.dat

I see:

fonts.dat: Zip archive data, at least v2.0 to extract

-rw-r--r-- 1 emmalyn emmalyn 1794977 Dec 17 10:18 fonts.dat

and Zork starts nicely.

Thanks for your patience.

comment:4 Changed 5 months ago by bluegr

The error message shown in this case is very cryptic and generic. It would be better if it was more explicit as to *which* data file is missing, i.e “Cound not load data file fonts.dat. Please download it from the extras section of the ScummVM website”

comment:5 Changed 5 months ago by bluegr

Cound -> Could

Note: See TracTickets for help on using tickets.