Opened 11 months ago

Closed 8 months ago

#10813 closed defect (wontfix)

QFG4: Wrong voice from Franz at the inn, Trina rumor

Reported by: Vhati Owned by: bluegr
Priority: low Component: Engine: SCI
Keywords: SCI32 original Cc:
Game: Quest for Glory 4

Description

ScummVM 2.1.0git3879-gb203b61b38 (Nov 13 2018 04:24:02)
Windows 7 64bit
QFG4 CD (English)

After saving Tanya, ask the peasants at the inn about rumors. It's the one where they say Tanya was overheard playing where the staff used to be, singing, "Trina's in love."

Their options at that point are: Monsters, Rumors, Townspeople, Elephants.

The message at fault is...

  • message pool 322 - noun:10, verb:147, cond:48, seq:2
    • Text: "Perhaps we do tell things about others occasionally."
    • Voice: "You must mean my apartment. We know of no cave in Mordavia." (bug)

That wrong voice was a copy of...

  • message pool 322 - noun:10, verb:147, cond:12, seq:2
    • Text: "We know of no cave in Mordavia."
    • Voice: "You must mean my apartment. We know of no cave in Mordavia."



Technically I haven't confirmed that original interpreter does this. I've no original saves that far in. The resource is at fault. I expect it would.


File - 5kb MD5 - Full MD5
RESOURCE.000 - 263dce4aa34c49d3ad29bec889007b1c - 1364ba69e3c0abb68cc0170650a56692
RESOURCE.AUD - c39521bffb1d8b19a57394866184a0ca - 71098b9e97e20c8941c0e4812d5f906f
RESOURCE.MAP - aba367f2102e81782d961b14fbe3d630 - 801a04cc6aa5d437681a2dd0b6545248
RESOURCE.SFX - 3cf95e09dab8b11d675e0537e18b499a - 7c858d7253f86dab4cc6066013c5ecec

Attachments (1)

sci.067 (89.7 KB ) - added by Vhati 11 months ago.
SavedGame (CD) - Ask about rumors

Download all attachments as: .zip

Change History (7)

by Vhati, 11 months ago

Attachment: sci.067 added

SavedGame (CD) - Ask about rumors

comment:1 by Vhati, 11 months ago

Quick and very dirty way to reproduce this.

  • Create a new character.
  • Set bitmasks for relevant plot flags.
    • vv g 507 4291
    • vv g 508 60413
    • vv g 509 41729
  • Fake an evening.
    • vv g 123 4
  • Teleport to the bed.
    • room 330
  • Walk downstairs, and ask about rumors.

comment:2 by Vhati, 11 months ago

@digitall:
Would you mind replicating this other voice bug with your copy?

comment:3 by digitall, 11 months ago

@Vhati: Done. Both with savegame and your quick and dirty method, I can replicate the issue where the second peasant talks about the apartment rather than the matching text.

comment:4 by sluicebox, 11 months ago

This is a resource bug. Gabriel Knight 1 has a somewhat similar one that was fixable, but I'd be impressed if we get that lucky again. The question is, does the actual audio for this message exist in the game? If it does then we can fix this. If it doesn't... enjoy the cave?

It's not a script bug, the scripts are playing the right message. The audio resource associated with that message is simply the wrong audio.

The message with the right text but the wrong audio is:
"Perhaps we do tell things about others occasionally"
modNum: 322 noun: 10 verb: 147 cond: 28 seq: 2

The game expects there to be an audio36 resource with those same numbers, which there is, but unfortunately that audio is "... apartment, We know of no cave in Mordavia" (I can't make out the first word)

This is the audio for this message:
"We know of no cave in Mordavia"
modNum: 322 noun: 10 verb: 147 cond: 12 seq: 2

The audio for that message is the same.

If we were lucky then they would have accidentally swapped the resources and both audio resources would be wrong. Then we could just reverse them. Instead they duplicated one audio file in the place of another. This means it's unlikely that the real audio for the first message exists in the universe.

Or maybe not? If you dump all the audio resources in resource 322, or maybe the entire game, and listen to them you might find that the message exists, just with a non-existent message tuple so that it's been orphaned and never played. This was the case with Gabriel Knight 1 and so it was fixable.

comment:5 by sluicebox, 10 months ago

There are six orphaned audio tracks in the game and this message isn't one of them.

comment:6 by bluegr, 8 months ago

Owner: set to bluegr
Resolution: wontfix
Status: newclosed

This is an error with the game resources. There’s not much we can do about it, since there’s no appropriate audio track

Closing as wontfix

Note: See TracTickets for help on using tickets.