#10783 closed defect (invalid)

SAGA: IHNM Mac Version Errors Out in Quicktime Music

Reported by: teknik667 Owned by: bluegr
Priority: normal Component: Engine: SAGA
Keywords: regression Cc:
Game: I Have No Mouth

Description

scummvm 2.1.0git3803-gc84480b1c8

When i start the game it shows the company logos and then it exits with the error:
" ERROR MusicDriver::playQuicktime(): Failed to load file 'Music/Music20' "

my OS: is WINDOWS 7 ULTIMATE SP1

i randomly tried the game with scummvm version 1.1.0 and it works.

Change History (5)

comment:1 by teknik667, 12 months ago

Component: --Unset--Engine: SAGA

comment:2 by digitall, 12 months ago

Keywords: regression added
Summary: I HAVE NO MOUTH AND I MUST SCREAM (MACINTOSH ENGLISH VERSION)SAGA: IHNM Mac Version Errors Out in Quicktime Music

comment:3 by digitall, 12 months ago

@teknik667: Thanks for the bug report. Please add the file md5sums to help identify your version.

We have already eliminated corrupt / bad datafiles from your forum post.

Can you try with v1.5.0, v1.6.0 etc. to see between what releases this regression was introduced as between v1.1.0 and latest v2.1.0 is a very large bisection area to analyse for the regression cause.

comment:5 by bluegr, 12 months ago

Owner: set to bluegr
Resolution: invalid
Status: newclosed

This is not a bug. The Mac version of IHNM has its music files stored in both resource and data forks. You have only copied the data fork here - I've just verified this with my copy. Thus, you will need to extract the music files in MacBinary format on PC platforms. Follow the instructions here:

https://wiki.scummvm.org/index.php?title=HOWTO-Mac_Games

Earlier versions of ScummVM read the files incorrectly, disregarding the resource fork, which is why this sort of worked.

Closing as invalid

Note: See TracTickets for help on using tickets.