#10762 closed defect (duplicate)

QFG4: Screenshots within savegames obscured by control panels

Reported by: Vhati Owned by: bluegr
Priority: normal Component: Engine: SCI
Keywords: SCI32 Cc:
Game: Quest for Glory 4

Description

ScummVM 2.1.0git3770-g15306581ab (Oct 18 2018 04:27:32)
Windows 7 64bit
QFG4 CD (English)

In the restore menu, every saved game (except autosave) has an embedded screenshot of the control panel, with the room peeking around the edges. It'd be more informative if that UI were hidden when generating the screenshot.

Workaround: There's no UI clutter if you bypass the control panel with a hotkey (F5).

Hm, the control panel currently disappears when you leave the save menu anyway (having either saved/canceled). Might as well hide it sooner, when it spawns the save menu.

File - 5kb MD5 - Full MD5
RESOURCE.000 - 263dce4aa34c49d3ad29bec889007b1c - 1364ba69e3c0abb68cc0170650a56692
RESOURCE.AUD - c39521bffb1d8b19a57394866184a0ca - 71098b9e97e20c8941c0e4812d5f906f
RESOURCE.MAP - aba367f2102e81782d961b14fbe3d630 - 801a04cc6aa5d437681a2dd0b6545248
RESOURCE.SFX - 3cf95e09dab8b11d675e0537e18b499a - 7c858d7253f86dab4cc6066013c5ecec

Change History (2)

comment:1 by Vhati, 14 months ago

I'm not familiar with ScummVM's internals. Maybe it *is* toggling visibility early but neglected to repaint before the modal save menu?

comment:2 by bluegr, 14 months ago

Owner: set to bluegr
Resolution: duplicate
Status: newclosed

Duplicate of bug #9752.

Closing

Note: See TracTickets for help on using tickets.