Opened 12 months ago

Closed 12 months ago

Last modified 12 months ago

#10752 closed defect (fixed)

MOHAWK: MYST25: RIVEN25: Our current custom build crashes on resize and alt-tab

Reported by: MDogherra Owned by: MDogherra
Priority: normal Component: Engine: Mohawk
Keywords: MYST25 Cc:
Game: Myst

Description

Hey all,

Afraid we're running into a crash on our current build when alt-tabbing, or resizing the window. I believe our current build (modified for the new splash screen) is built on the 2.1.0 Oct.1 git release, which we're seeing it on as well. I've attached our current exe.

Attachments (1)

myst25.ini (1.8 KB ) - added by MDogherra 12 months ago.
Our config ini for release

Download all attachments as: .zip

Change History (11)

comment:1 by MDogherra, 12 months ago

Looks like the binary is a bit too big for the bugdb, I'll toss it your way in an email

comment:2 by digitall, 12 months ago

The binary is probably not that much use to us, at least initially.

If you can replicate this with a nightly or daily build from here, that would confirm that the problem is not in your local build environment or code modifications:
https://www.scummvm.org/downloads/#daily

You have omitted some of the information requested from new bug submissions which would be relevant, specifically:
ScummVM version (scummvm -v)
Your OS, including version and device if appropriate (Windows 10 build 1709 32-bit, Debian 9.2 x86_64, Android 7.0 on Samsung Galaxy S7, ...)

The scummvm -v from your custom build would also indicate what libraries / features have been built against so would be useful.

comment:3 by digitall, 12 months ago

Just tried replicating here with latest git master af580eaa853b2434c0d237cff49f7f273444a06d on Linux x86_64 with no success. Switching out of fullscreen and Alt-Tab work as expected and resizing in nominal windowed mode shows no issues. This is when built against SDL-2.0.8 which is the latest stable release.

I assume this may be a Windows specific issue? If so, you would probably need to run the build with a debugger and try to get a backtrace at the crash to see where and why this is crashing...

by MDogherra, 12 months ago

Attachment: myst25.ini added

Our config ini for release

comment:4 by MDogherra, 12 months ago

We're seeing this on win7 32bit, 8.1 32bit, and current 10 64bit.

Not seeing any command line output for the -v argument, I do have this in the log output however:
[2018-10-22 09:54:27] ScummVM 2.1.0git (Oct 2 2018 20:03:40)
[2018-10-22 09:54:27] Vorbis FLAC MP3 RGB zLib MPEG2 FluidSynth Theora AAC FreeType2 JPEG PNG

Grabbing the latest daily (32 and 64, win10pro 64), I'm unable to resize the window, alt tab seems to have some odd issues with taking screen focus. Makes me wonder if it's something to do with our config ini. I'll attach it as well.

@Bastien
Here's what I'm getting back from the gdb bt full output when resizing the window, and alt-tab:
Program received signal SIGSEGV, Segmentation fault.
0x0000002b in ?? ()
(gdb) bt full
#0 0x0000002b in ?? ()
No symbol table info available.
(gdb)

comment:5 by criezy, 12 months ago

I am wondering if this might be a libSDL bug. There are various report of similar issues with SDL (such as https://discourse.libsdl.org/t/sdl-pollevent-freezes-on-alt-tab/21924). Maybe using a more recent version of the SDL library when compiling would fix this?

@MDogherra: if you cannot resize the window with the daily build, I suspect this is because it is using an even older version of the SDL library (with SDL 1.2 the window could only be resized when using OpenGL graphics mode, while with SDL 2.0 it can always be resized). We actually have two different daily builds for Windows, and if I remember correctly the one on buildbot (the first of the two links on https://www.scummvm.org/downloads/#daily) indeed uses the older SDL library, but the second one below (labeled as "Provided by ScummVM Team member Travis 'Kirben' Howell") uses a more recent SDL library. So you might want to try with the second one if this is not the one you tried already.

comment:6 by MDogherra, 12 months ago

Awesome, thanks much, the more recent SDL build is working perfectly. I'll have our dev see about making a new build against the new sdl.

comment:7 by digitall, 12 months ago

Owner: set to criezy
Resolution: worksforme
Status: newpending

Have compared the SDL2.dll from Kirben's last daily build with the pre-built versions from the libSDL project. The included DLL is an exact MD5sum match to SDL2-2.0.5-win32-x86/SDL2.dll with a value of ec15b044a46bf6e411f9eba551858030.

If switching your existing SDL2.dll in your builds with the latest v2.0.8 x86 DLL or at least that v2.0.5 one should fix the issue.

Setting this bug as pending at worksforme.

@MDogherra: Please update this bug to confirm if your issue is fixed.

comment:8 by MDogherra, 12 months ago

With a new build against the newer sdl, we're working perfectly, and will ship this as an update for riven and myst on steam here in a bit. Thanks everyone!

comment:9 by MDogherra, 12 months ago

Owner: changed from criezy to MDogherra
Resolution: worksformefixed
Status: pendingclosed

comment:10 by dafioram, 12 months ago

Using the SDL (2.0.8) did not work for me since Win10 will make the top right corner of the screen not clickable because of the Windows 10 Gamebar see #10586.

Please verify that #10586 does not happen on your win10 machines.

Note: See TracTickets for help on using tickets.