#10718 closed defect (fixed)

GUI: Mouse Cursor Flickering While Moving In Fullscreen

Reported by: necros2k7 Owned by: necros2k7
Priority: normal Component: Port: Win32
Keywords: Cc:
Game:

Description (last modified by digitall)

Mouse cursor flickering while moving it in circles fullscreen

Change History (13)

comment:1 by digitall, 15 months ago

Priority: highnormal

comment:2 by digitall, 15 months ago

Description: modified (diff)
Summary: mouse cursor flickering while moving it in circles fullscreenSWORD1: Mouse Cursor Flickering While Moving In Fullscreen

comment:3 by digitall, 15 months ago

Have attempted to replicate this from a new game in the first scene outside the cafe. This is using the latest master i.e. 9b56d7c6bcd89d99f9046315a6a23f0821693974 under Linux in Fullscreen, with both default and OpenGL graphics output.

While there is some "flicker", this is just the normal mouse pointer redraw / refresh and I can not spot anything pathological or different from the original game interpreter.

@necros2k7: Can you supply the information which is listed in the New Ticket page, especially what version of ScummVM you are using and on what platform?
<snip>

Please check you are including all the following information in your bug report:

ScummVM version (scummvm -v)
Bug details, including step-by-step instructions to reproduce the bug
Language of game (English, German, ...)
Version of game (CD, Floppy, DOS, Amiga, ...)
Your OS, including version and device if appropriate (Windows 10 build 1709 32-bit, Debian 9.2 x86_64, Android 7.0 on Samsung Galaxy S7, ...)
Attach a save game if possible
If this bug only occurred recently, please note the last version without the bug, and the first version including the bug. That way we can fix it quicker by looking at the changes made.
Next, select the game in the 'Game' dropdown, and the game engine or other component in the 'Component' dropdown. Enter your text, and hit the button!

</snip>

If this occurs at some point into the game, a savegame at that point would be good as well.

Since I can NOT replicate this currently, am going to change status to pending (on submitter feedback). If there is no update within 30 days, this bug should be closed as invalid.

Last edited 15 months ago by digitall (previous) (diff)

comment:4 by necros2k7, 15 months ago

correction - it flickers even in SCUMMVM GUI in the game list menu (2.1.0git3702 sep 27 2018 daily build) win10 x64

Last edited 15 months ago by necros2k7 (previous) (diff)

comment:5 by digitall, 15 months ago

Component: Engine: Sword1GUI
Summary: SWORD1: Mouse Cursor Flickering While Moving In FullscreenGUI: Mouse Cursor Flickering While Moving In Fullscreen

Changing to GUI / Backend as that sounds like an issue with either GUI refresh code or Graphics backend for Windows i.e. SDL

@necros2k7: What Launcher->Options->Graphics Mode are you using? If default / Normal, try the OpenGL backend, or if using OpenGL, try the default output...

Just that the SDL has different paths for GL and normal 2D graphics output... If you are using GL, this may be an issue with your GFX card / drivers.

comment:6 by digitall, 15 months ago

Game: Broken Sword 1

comment:7 by necros2k7, 14 months ago

yes, no flickering while in GL mode

comment:8 by digitall, 14 months ago

I think that the standard Win32 builds are shipping with SDL2.dll which is the v2.0.5 release. See:
https://bugs.scummvm.org/ticket/10752

This might be an issue in SDL2 which has been fixed upstream. Maybe try replacing the "stock" ScummVM SDL2.dll with a newer release binary from libSDL.

The current latest stable is v2.0.9, but maybe try with that and other versions v2.0.6 to v2.0.8:
https://www.libsdl.org/download-2.0.php

Please update us if this fixes your issue.

comment:9 by digitall, 14 months ago

Owner: set to digitall
Resolution: worksforme
Status: newpending

comment:10 by necros2k7, 14 months ago

Did some tests: 1. no, win32 builds use SDL
(graphics mode 2x, win10 x64 , i7 , nvidia)
dll vers - 1.2.11-1.2.15 - flickering cursor while moving in circles

1.2.5.0, 1.2.9.0 - no flickering)

comment:11 by digitall, 14 months ago

Component: GUIPort: Win32
Resolution: worksforme
Status: pendingnew

Ah. I think the issue here is that buildbot Win32 builds are still using SDL1 and that is the latest version so probably a bug from that.

We should probably offer SDL2 as an option for Win32 builds on buildbot. Will take a look at sorting that.

comment:12 by digitall, 13 months ago

Resolution: fixed
Status: newpending

bgK has migrated the buildbot standard win32 builds from SDL1 to SDL2, so this is likely "fixed".

Will set this to pending as fixed.

@necros2k7: Please test with the next nightly build and confirm here if this solved your issue?

comment:13 by necros2k7, 13 months ago

Owner: changed from digitall to necros2k7
Status: pendingclosed

yes it did thanx!

Note: See TracTickets for help on using tickets.